• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 getting these errors on install of 1.5.5

#1
Getting this when doing a fresh install the upgrade from 1.4.5 wouldnt work so I deleted the directory and the tables and then reuploaded the 1.5.5 but keep on getting this


Server Error

Server Error
No entry is registered for key 'db'

  1. XenForo_Application::get() in XenForo/Application.php at line 1607
  2. XenForo_Application::getDb() in XenForo/Session.php at line 236
  3. XenForo_Session->__construct() in XenForo/Install/Controller/Upgrade.php at line 46
  4. XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 306
  5. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 350
  6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  7. XenForo_FrontController->run() in /home/dreamhil/public_html/Community/install/index.php at line 18
 

Brogan

XenForo moderator
Staff member
#2
What is the URL where you are trying to install?

If you have deleted all of the server files and dropped the tables, the install script should start automatically.

I wonder whether server cache is involved here - serving old files.
 

Brogan

XenForo moderator
Staff member
#4
You appear to have some missing files.
Fatal error: Class 'Zend_Controller_Request_Http' not found in /home/dreamhil/public_html/Community/library/XenForo/FrontController.php on line 248

Download a fresh copy of the archive from your customer area and try uploading the files again.

Rather than deleting the installation, if you had posted we would have likely been able to resolve the upgrade issue.