1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Xenforo Installation on Xampp

Discussion in 'Troubleshooting and Problems' started by akhi_234, Sep 6, 2015.

  1. akhi_234

    akhi_234 Member

    I am try to install xenforo on my local environment and use copy of my website's db. After copying content of upload folder in the community folder in htdocs, when i try to run install, i am receiving following error;
    Server Error
    Server Error
    No entry is registered for key 'db'

    1. XenForo_Application::get() in XenForo/Application.php at line 1607
    2. XenForo_Application::getDb() in XenForo/Session.php at line 236
    3. XenForo_Session->__construct() in XenForo/Install/Controller/Upgrade.php at line 46
    4. XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 306
    5. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    7. XenForo_FrontController->run() in C:/xampp/htdocs/topuniversityforum/install/index.php at line 18
    Please help.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Why are you running the installer if you are using a backup of the production database?

    If you are going to do a new installation, do it as normal, then import the database afterwards.

    This guide should help: How to install XenForo locally to your PC using XAMPP

Share This Page