XF 2.2 Getting Servererror (5xx) inside Google Search Consoles

Hi,

Can someone tell me why I get a servererror (5xx). Some threads are not being indexed.

I added the sitemap.php to search console and its correct.

Thanks,
Amro
 

djbaxter

Well-known member
Error 500 means your server was down or misconfigured when googlebot visited.

If you can confirm that your site is currently accessible, normally you don't have to take any further action, unless this is happening frequently in which case you should contact support for your host and find out why.
 
Error 500 means your server was down or misconfigured when googlebot visited.

If you can confirm that your site is currently accessible, normally you don't have to take any further action, unless this is happening frequently in which case you should contact support for your host and find out why.

What can be misconfigured? The server or xenforo settings?

Thanks for your reply!
 

djbaxter

Well-known member
Error 500 means it's the server not Xenforo.

If you only occasionally see this, it may mean nothing more than a temporary problem accessing your site, which can oicur for several reasons. You host should be able to access the server logs to determine what happened.

If it's happening frequently, that's more serious. Either there's an issue with how the server is configured or you just need a new host.

If you're using shared hosting, it could mean that one of the other accounts on the same server is crashing Apache or the SQL server or something similar. This is less likely with a VPS but not out of the question.

I see this error from time to time on dedicated servers as well.

But step 1 is to ask your host what's happening.
 

briansol

Well-known member
I have a few random ones that don't make sense either.

quotes and searches.

thread.id/reply?quote=id
search/nnnnn/

are common ones i have.

The first should probably should 403 or otherwise redirect to login, but it shows as a 500 in Google.

I can load it with a 200 in an incognito window (aka, not logged in)
so, i'm not really sure what is going on. Actually, thinking on this more, i do allow writing before registering so this should simply be a 200 good page with a login screen after it.

search pages, these are all old expired searched and they log as a 404 in my console, so i'm not sure why it's a 500 for google.
 

djbaxter

Well-known member
I can see the search page as a soft 404, but the reply is not
That's not what I meant. I meant that Google has acknowledged there are some current errors being generated by Search Console. They have acknowledged mislabeling soft 404 errors but I was suggesting there may be other mislabeled errors also being generated.
 
Top