1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting Server Errors after Moving XenForo Directory

Discussion in 'Installation, Upgrade, and Import Support' started by polkunus, Oct 20, 2011.

  1. polkunus

    polkunus New Member

    Hello,

    I recently switched from having XF in my server root IP/xenforo to one of my virtual web servers: IP/www.afterkraft.com/htdocs/afterboards .

    Whenever I directly go to www.afterkraft.com/afterboards apache spits out an error:
    Screen Shot 2011-10-20 at 2.12.39 PM.png

    I put an index.html file in the root directory of the website IP/www.afterkraft.com/htdocs/index.html and it seems to work fine.

    I have already changed the board information at:

    Screen Shot 2011-10-20 at 2.14.29 PM.png

    My .htaccess is written as:

    Keep in mind that the website works completely fine through IP/www.afterkraft.com/htdocs/afterboards , but not www.afterkraft.com/afterboards
    What's going on here? Is there anything I did wrong? Any help would be much appreciated.
     
  2. CyclingTribe

    CyclingTribe Well-Known Member

    If you can access ACP - have you checked XF's error logs?

    Also check the Apache error_log file to see if there is any more info on the 500 error?
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    An internal server error is generic and can mean many things. Ideally the server log will have more information about the error.

    Some things to try:

    1) Remove your .htaccess file.

    2) Check your file/folder permissions on the server.

    3) Make sure PHP works by uploading a phpinfo file.
     
  4. polkunus

    polkunus New Member

    Thanks for the input guys!

    Php works here: http://www.afterkraft.com/ (I understand its a bit dangerous I'll pull it down in a bit)

    Removed .htaccess, samething

    Changed all perms on the root folder of www.aftercraft.com to 777

    I can access ACP absolutely fine, just through "the long way":
    Screen Shot 2011-10-20 at 2.51.03 PM.png

    The only thing the apache logs say are favicon errors
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Since you can access the Admin CP, try disabling your addons, and run a file check:

    Admin CP -> Tools -> File Health Check
     
  6. polkunus

    polkunus New Member

    I can't seem to find this button... Where is it exactly?
    Screen Shot 2011-10-20 at 3.08.46 PM.png

    I'm able to access the entire site and all the features work perfectly fine. I'm just having trouble accessing it the way I'd like it to be accessed. Via www.afterkraft.com/afterboards. Going through my directories and manually connecting via web browser on [www/var(Basically my IP)]/www.afterkraft.com/htdocs/afterboards works totally fine. The apache virtual servers are set up absolutely fine, its just Xenforo is having trouble running under the "www.afterkraft.com/afterboards" URL for some reason

    I'm really bummed out, I have no idea why this is happening.

    I even tried adding a syslink from my var/www/xenforo (where it was originally hosted) to the /var/www/www.afterkraft.com/htdocs/xenforo and it STILL spat out the same message via www.afterkraft.com/xenforo

    edit: Lastly if a (reputable/trustable) kind soul really wants to help... I can probably give him/her ftp/ssh access... I just really need this done and I've been searching for hours and I can't seem to find a solution..
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Regarding the file check... what version of XenForo are you using? That feature was added in 1.0.3.

    I can take a look if you give me FTP and admin access.
     
    GeeksChat likes this.
  8. CyclingTribe

    CyclingTribe Well-Known Member

    Just to confirm that Jake knows his stuff and giving him FTP and Admin access poses no risk whatsoever - he da man when it comes to support - he hates a system getting one over on him ... lol !! (y)
     
    dwdmadmac and Dan like this.
  9. dwdmadmac

    dwdmadmac Active Member

    So I am having the same issue and I did what you said above. and this is what I received

    Any suggestions?
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Upload the files again.

    If it continues to happen, download the upgrade package, extract those two files and upload them once more.

    If it still happens, use a different FTP program.
     
  11. dwdmadmac

    dwdmadmac Active Member

  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    In some server configurations an excess of permissions can cause this error. Here are the typical file / folder permissions:

    Folders = 755
    Files = 644
    "data" and "internal_data" = 777
     
  13. dwdmadmac

    dwdmadmac Active Member


    I have took those steps already and still receiving this error. It is weird Forums have been running good for a while now. over a month. I just purchase liquid Pro Simple Forums and once I tried to install, Then I received this error. Not saying that is why I am receiving this I am just try'n not to rule it out. ?
     
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you are comfortable giving me FTP and admin access.
     
  15. dwdmadmac

    dwdmadmac Active Member

    Sure thing Ill make you an FTP account and admion access as in forum admin access?
     

Share This Page