1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Getting Error Suddenly

Discussion in 'Troubleshooting and Problems' started by TheMacGenius, Jul 4, 2013.

  1. TheMacGenius

    TheMacGenius New Member

    I just tried to access my website today, only to find a lovely error preventing me from doing so. I get the following error when I try to access my site:


    Warning: require(/home/mineuniv/public_html/library/XenForo/Autoloader.php) [function.require]: failed to open stream: No such file or directory in /home/mineuniv/public_html/index.php on line 6

    Fatal error: require() [function.require]: Failed opening required '/home/mineuniv/public_html/library/XenForo/Autoloader.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mineuniv/public_html/index.phpon line 6


    The strange thing is, my site was working fine one day, then the next it was down, and I haven't change anything on the site (I didn't even connect through ftp to the site). THe strange thing is, now when I look in the /home/mineuniv/public_html directory, there is no 'library' folder. I was wondering if the site just somehow deleted it, or if there is anyway to restore this missing file. Any help would be appreciated.

    Thanks
     
  2. TheMacGenius

    TheMacGenius New Member

    Nvm, problem was solved, I found the 'library' folder located inside of the internal_data folder, I guess somehow it got moved, or maybe I moved it earlier and it just hadnt had this error until now.
     

Share This Page