• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

getting error from sql

Ian S

Active member
#1
hi im trying to put a full import of the vb db in my db but i keep getting the error attached, the file is 1.1gb of pictures in the sql ive tried through ssh and through phpmyadmin, and ive changed all the settings too

any help apprec, just wanted to leave the dev site alone and do it off line, can i point the attachments to my pc directory or does it have to be a server

thanx
 

Attachments

#2
I'm not too sure but is it possible that there is a size limit on the size? The attached image says 'Row size to large" That is why I suggest that anyway you can compress the entire thing and try it that way?
 

Ian S

Active member
#3
this is what i thought but it failed in ssh too, ive extended all the settings to way over this size and it still failed so you recommend me zipping just the picture file keith??? thanx
 
#4
I'm no expert I was trying to figure out a solution perhaps zipping it might work. I do know that zipping will decrease the file size and it's very possible that is why you are getting this error. However, I don't want to give you wrong information that will mess up your stuff either.
 

Jim Boy

Well-known member
#9
how big did you extend it to, 256MB?

from MySQL

As a result of the redo log BLOB write limit introduced for MySQL 5.6, innodb_log_file_size should be set to a value greater than 10 times the largest BLOB data size found in the rows of your tables plus the length of other variable length fields (VARCHAR, VARBINARY, and TEXT type fields). Failing to do so could result in “Row size too large” errors. No action is required if your innodb_log_file_size setting is already sufficiently large or your tables contain no BLOB data. (Bug #16963396, Bug #19030353, Bug #69477)