XF 2.0 Friendly URLs not Working

Z

Zarken

Guest
Hey, i've tried using https://xenforo.com/help/friendly-urls/ to get Friendly URLs working but my website just errors with '404 Not Found' i'm using Nginx, here's my config - well most of it anyway:

Code:
server {
    root /var/www/html;
    index index.html index.htm index.nginx-debian.html index.php;
    server_name gidentity.net www.gidentity.net;
    
    location / {
        try_files $uri $uri/ /xf/index.php?$uri&$args;
    }

    location /install/data/ {
        internal;
    }
    location /install/templates/ {
        internal;
    }
    location /internal_data/ {
        internal;
    }
    location /library/ {
        internal;
    }

    location ~ \.php$ {
        fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
        include snippets/fastcgi-php.conf;
        fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        
        include         fastcgi_params;
    }
}

server {
    if ($host = www.gidentity.net) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


    if ($host = gidentity.net) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


    listen 80 default_server;
    listen [::]:80 default_server;

    server_name gidentity.net www.gidentity.net;
    return 404; # managed by Certbot
}

Is there anything missing?
 
Z

Zarken

Guest
Thats in with the SSL cert stuff i cut out - i'll just put that whole block in to avoid further confusion.

Code:
listen [::]:443 ssl ipv6only=on; # managed by Certbot
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/gidentity.net/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/gidentity.net/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

Sorry about that :3


Still not working, anyone have any idea?
 
Last edited by a moderator:
Top