1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Friendly URLS Help

Discussion in 'XenForo Questions and Support' started by SkyLarkPvP, Jan 14, 2015.

  1. SkyLarkPvP

    SkyLarkPvP Member

    Hello, I'm using nginx to host my xenforo website and was wondering where the nginx server configuration was so i could configure friendly URLS.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. SkyLarkPvP

    SkyLarkPvP Member

    @Brogan
    That link shows me how to install friendly URLS, I'm not sure where the nginx server configuration is though.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. SkyLarkPvP

    SkyLarkPvP Member

    @Brogan
    Ok, well I put the code for nginx friendly urls inside the nginx.conf and enabled friendly URLS, however when I restart nginx it just says:
    * Reloading nginx configuration nginx [fail]

    Heres what I put in my nginx.conf:
    user www-data;
    worker_processes 4;
    pid /run/nginx.pid;

    events {
    worker_connections 768;
    # multi_accept on;
    }

    location /usr/share/nginx/html/ {
    try_files $uri $uri/ /usr/share/nginx/html/index.php?$uri&$args;
    index index.php index.html;
    }

    location /usr/share/nginx/html/internal_data/ {
    internal;
    }
    location /usr/share/nginx/html/library/ {
    internal;
    }

    location ~ \.php$ {
    try_files $uri =404;
    fastcgi_pass 127.0.0.1:9000;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    }

    http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # nginx-naxsi config
    ##
    # Uncomment it if you installed nginx-naxsi
    ##

    #include /etc/nginx/naxsi_core.rules;

    ##
    # nginx-passenger config
    ##
    # Uncomment it if you installed nginx-passenger
    ##

    #passenger_root /usr;
    #passenger_ruby /usr/bin/ruby;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
    }


    #mail {
    # # See sample authentication script at:
    # # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    # # auth_http localhost/auth.php;
    # # pop3_capabilities "TOP" "USER";
    # # imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    # server {
    # listen localhost:110;
    # protocol pop3;
    # proxy on;
    # }
    #
    # server {
    # listen localhost:143;
    # protocol imap;
    # proxy on;
    # }
    #}
     
  6. SkyLarkPvP

    SkyLarkPvP Member

    Can anyone please help?
     

Share This Page