1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Friendly URL Problem

Discussion in 'Troubleshooting and Problems' started by sillyrosster, Jul 18, 2012.

  1. sillyrosster

    sillyrosster Member

    I'm not sure how to get friendly url's working. Is there a topic you can point me to or tell me how to get them working here?
     
  2. Vincent

    Vincent Well-Known Member

    Admin CP --> Options --> Basic Board Information --> Search for "Use Full Friendly URLs" :)
     
  3. sillyrosster

    sillyrosster Member

    I know how to do that, but when I do, I start getting errors on every page but the home page.
     
  4. Vincent

    Vincent Well-Known Member

    Would you mind showing the error message?
     
  5. Jeremy P

    Jeremy P Well-Known Member

    Make sure the .htaccess file exists in your XenForo root directory, unless you're not using Apache..
     
  6. sillyrosster

    sillyrosster Member

    This is what I get when I enable it: http://pastie.org/4279362
    It's there.
     
  7. -Ice-

    -Ice- Active Member

    From http://xenforo.com/help/friendly-urls/
    Do you have shell access to your server?
     
    Jake Bunce likes this.
  8. sillyrosster

    sillyrosster Member

  9. sillyrosster

    sillyrosster Member

    Going to revive this thread because I never actually got it working :(

    I did check to see if mod_rewrite was installed and the .htaccess file is there, so I don't know what else it could be.

    Any help would be appreciated, as this has been bugging me for the past few months.
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

    1) Your server doesn't have mod_rewrite installed.

    2) Your server doesn't have AllowOverride enabled:

    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    3) The .htaccess file is not in place in your forum directory.

    4) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    Code:
    RewriteBase /xenforo
    
     
  11. sillyrosster

    sillyrosster Member

    I would think that it would be /forum, would I be right to think that?
     
  12. cclaerhout

    cclaerhout Well-Known Member

    Actually it depends in which directory you've installed XenForo ;)
     
  13. sillyrosster

    sillyrosster Member

    It's called public_html. That is where all the XenForo files/folders are.
     
  14. cclaerhout

    cclaerhout Well-Known Member

    You still need to configure RewriteBase when the files are at the root of your server...?o_O It sounds strange.
    Next time, don't do this: use specific folders for any of your scripts.
     
  15. sillyrosster

    sillyrosster Member

    I didn't name the folder.

    Edit: I've done everything I an think of and it still gives me the same error. I don't want to be stuck without friendly urls enabled :(
     
  16. cclaerhout

    cclaerhout Well-Known Member

    If it's a blank forum, I recommend you to do it again. It should be very fast.
     
  17. sillyrosster

    sillyrosster Member

    Hehe, not blank - www.metaserve.net

    Edit: This thread was first opened in July.
     
  18. cclaerhout

    cclaerhout Well-Known Member

    Too bad... may be problem is coming from there... (I mean that XenForo has been installed to the root of your server )
     
  19. sillyrosster

    sillyrosster Member

    It's not the root? I said it's in a folder called 'public_html'. I don't even own the server, nor do I pay for any of it. A friend owns it and handles everything, so I have no access outside of that folder.
     
  20. cclaerhout

    cclaerhout Well-Known Member

    public_html is the "root" of your server for web pages.

    For more information, see here:
    http://httpd.apache.org/docs/2.2/howto/public_html.html
     

Share This Page