1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Friendly URL == Help

Discussion in 'Troubleshooting and Problems' started by Dzana, Jul 6, 2014.

  1. Dzana

    Dzana Member

    Hey Guys,

    I have a Problem with the Friendly URL.
    My .htaccess:

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
        RewriteRule ^/threads/ /forum/threads
    RewriteRule ^/forums/ /forum/forums

    My Forum is in the main Directory ( / )

    mod_rewrite is activated
  2. AndyB

    AndyB Well-Known Member

    As the instruction in the .htaccess say:

    Try removing the # and use just the forward slash:

    RewriteBase /
  3. Dzana

    Dzana Member

    Done, but it still don't want to work....
  4. Steve F

    Steve F Well-Known Member

    Have you enabled friendly URLs in the ACP?

    Options -> Search Engine Optimization (SEO) -> Use Full Friendly URLs
  5. Dzana

    Dzana Member

    Yes, I have.
  6. Tracy Perry

    Tracy Perry Well-Known Member

    There is (if I remember correctly) an allowOverRide setting that needs to be changed in the Apache vhost definition. I gave up on Apache a long time ago (nginx and OLS for me) but somebody may know exactly what it is.
  7. nodle

    nodle Well-Known Member

    This isn't part of the standard .htaccess file. Did you try to remove these? Might want to just for a test to see if these are the problem:

    RewriteRule ^/threads/ /forum/threads
    RewriteRule ^/forums/ /forum/forums

Share This Page