• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Friendly URL help...


Active member
I've got my forum in a directory "/forums" and I turned on friendly URL's. But now it goes... /forums/forums/[post/thread] how do I turn off the other 'forums' extension.

Hopefully I explained myself correctly.


Active member
# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

<IfModule mod_suphp.c>
 suPHP_ConfigPath /home/***
 <Files php.ini>
  order allow,deny
  deny from all

<Files 403.shtml>
order allow,deny
allow from all


Well-known member
Your .htaccess is much different than mine, although I also use friendly URL's.

Sorry I don't know .htaccess well enough to make a suggestion, hopefully someone else will.


Well-known member
You can't turn off the second forums extension. This is an internal route and required for proper functioning. 1.2 has a route changer where you can modify it, but there has to be something there.


Well-known member


Well-known member
Until they explain it further, I can only assume it isn't a double /forums/ everywhere (indicated by the brackets).


Well-known member
How do I change it? Wouldn't mind making it a little more content relevant maybe make it "nba" or "nba_forum
Per this example:



Home -> Route Filters -> Create new Route filter
Find Route: forums
Replace With: list
RouteFilters.png RouteFilters2.png


XenForo moderator
Staff member
The alternative of course is to change the /forums directory where the site is installed, or install it in the root.