• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Forum suggestion: Use prefixes to show compatible XenForo versions

Erik

Well-known member
#1
I realize this is probably the wrong place for this, but I figured it's the best place for it to get seen.

I propose that we use the new thread prefixes feature of XenForo in the Styles forum to label each theme with the latest version of XenForo it's compatible with. Currently it's impossible to tell if a style is updated for the latest version of XenForo without digging into the thread and looking for that information. If we created prefixes for each version of XenForo, it would be easy to tell which styles have been updated and which haven't.

Just a suggestion. :)
 

Brogan

XenForo moderator
Staff member
#5
Personally I'm against this.
If it happens for styles then the next request will be for add-ons, then template edits, etc.
Then of course there would be the 1.1.1 updates, 1.1.2 and so on.

I have enough to do as it is...

The style authors should be updating their first post stating clearly which release the style is compatible with.
 

Trombones13

Well-known member
#6
I think it's a good idea in theory, but would end up being too much of a hassle for staff and might be made unnecessary with the release of the Resource Manager anyway.
 

Shelley

Well-known member
#7
Personally I'm against this.
If it happens for styles then the next request will be for add-ons, then template edits, etc.
Then of course there would be the 1.1.1 updates, 1.1.2 and so on.

I have enough to do as it is...

The style authors should be updating their first post stating clearly which release the style is compatible with.
If authors had more control over the resources they submit then you wouldn't have anything to do. They would make use of the system (one of the benefits it was used for) and allow them to make appropriate changes to each versions.

I think it's a good idea Erik.
 

Allan

Well-known member
#9
Personally I'm against this.
If it happens for styles then the next request will be for add-ons, then template edits, etc.
Then of course there would be the 1.1.1 updates, 1.1.2 and so on.

I have enough to do as it is...

The style authors should be updating their first post stating clearly which release the style is compatible with.
If any one had permission for authors to edit them, they could, for example add [Style for XenForo 1.1.x] before the title. This applies to all resources.

No need prefix and less work for moderation.
 

Digital Doctor

Well-known member
#10
I propose that we use the new thread prefixes feature of XenForo in the Styles forum to label each theme with the latest version of XenForo it's compatible with.
Good idea.

But "compatible" with Version X isn't probably a yes/no question.
I think it would be nice for Styles to include the CSS / HTML needed to make nice Notices.
Style designers might think that is not their job.
Style designers might think that being compatible with XenPorta isn't manadatory, I think it is important.
So at the end of the day, updated Styles will need more of a description than just toggling 1.0 to 1.1

But a [1.1] prefix would show which style makers are committed to updating their styles. It would also reward people for doing so ... as if the filters were available, I am probably need a style sometime soon and I would see whom has updated their style to 1.1 already.

I think a prerequisite would be updating Xenforo to use the LGB Threadrenamer addon in the core.
 

TheRevTastic

Well-known member
#11
Good idea.

But "compatible" with Version X isn't probably a yes/no question.
I think it would be nice for Styles to include the CSS / HTML needed to make nice Notices.
Style designers might think that is not their job.
Style designers might think that being compatible with XenPorta isn't manadatory, I think it is important.
So at the end of the day, updated Styles will need more of a description than just toggling 1.0 to 1.1

But a [1.1] prefix would show which style makers are committed to updating their styles. It would also reward people for doing so ... as if the filters were available, I am probably need a style sometime soon and I would see whom has updated their style to 1.1 already.

I think a prerequisite would be updating Xenforo to use the LGB Threadrenamer addon in the core.
The first post would be there to say if the style supports XenPorta or not, same with if it comes with styled notices.

The tags should be used to show what version of XenForo is supported, as to be hones, style authors should only support XenForo Ltd products and not 3rd party addons.