1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Forbidden: You don't have permission to access admin.php on this server [ERROR]

Discussion in 'Troubleshooting and Problems' started by MsJacquiiC, Nov 8, 2014.

  1. MsJacquiiC

    MsJacquiiC Well-Known Member

    adminphp-error.gif

    This is the error I see when trying to edit a Xenporta template.
    I've seen a similar thread that mentions mod_security -- but I don't think this is my particular problem.

    To reproduce - I simply go to the template and try to edit any part of it. Clicking "Save All Changes" results in the Forbidden error. What's strange is that I can save the template when there are no changes made to it.

    Any assistance fixing this issue will be very much appreciated.
    Thanks!

    J.
     
  2. Martok

    Martok Well-Known Member

    Does it happen with other templates?
     
  3. Mike

    Mike XenForo Developer Staff Member

    I'm pretty sure that is indeed mod_security (or a similar system). When a page like that comes up, XenForo isn't even being run; the request is being blocked before it starts.
     
  4. MsJacquiiC

    MsJacquiiC Well-Known Member

    This is what's so strange! It doesn't happen in most other templates. There was another template that threw the error. But I've been able to edit other templates without issue. And it seems like if one template is showing the error - then all others would show the error as well. Kind of bizarre :(

    The client I'm working for had his tech support disable mod_security completely (so that I was told anyway...) and I'm still seeing the permissions error when editing (or rather - trying to edit) the EWRblock_RecentThreads template :(
     
  5. Mike

    Mike XenForo Developer Staff Member

    There should be logs in your web server error log that imply what is triggering the error then. Unfortunately, as it's being hit before XenForo is run (in that request), there isn't really anything we can do to stop it. It is likely to be something only your host can change though.
     
    Saburov and MsJacquiiC like this.

Share This Page