Fixed Filters dropdown button in list views

Affected version
XenForo 2.1.11

smozgur

Active member
This happens in Safari in Mac. No extension is installed in Safari.
It doesn't happen in Chrome or Firefox in the same computer.

When you click on the "Filters" button in any page contains list such as threads, resources, media, the page scrolls to the bottom of the page, just like the "Filters" anchor is referring to a named element - like the default action is not prevented in JavaScript. I just installed a demo to test it and I can confirm it happens in the original installation as well.

1601350676505.png

It also doesn't happen in version 2.2 latest candidate.
 

Chris D

XenForo developer
Staff member
I just created a demo here and was unable to reproduce the issue in macOS Catalina and Safari.


Just to be clear: All I've done is created some threads so that there is enough height on the page for it to be scrollable and click the "Filters" menu. The menu opens and the page doesn't scroll.

View attachment Screen Recording 2020-09-29 at 10.39.44.mov

Even so, I'd have said that if this was reproducible in XF 2.1 but not in XF 2.2 then we'd be comfortable calling it fixed.

If there's more to this let us know, otherwise I'll close this off for now.
 

Chris D

XenForo developer
Staff member
Yeah mine was first click (I reloaded the page before doing it).

Quite an odd behaviour - what version of macOS are you using? Are you using macOS Big Sur Beta or Catalina?
 

smozgur

Active member
It doesn't happen in 2.2. So it is ok.
I considered to let you know just in case for 2.1.11 support for forums need to run it.
 

Chris D

XenForo developer
Staff member
Actually it does seem like it happens in 2.2.

I think it's going to end up being a browser issue but I'll move it back so we can keep an eye on it.
 

Chris D

XenForo developer
Staff member
You don't seem to be using vanilla Safari because you have the privacy report button:

1601385144829.png

I can only see that button on macOS 11 or in Safari Tech Preview on 10.16. I believe it's a new feature.

I can also only reproduce the same results as your original video if I'm using Safari Tech Preview.

Demo is on 2.2? I didn't think you use unstable version for demo.
This site is on 2.2.
 

smozgur

Active member
You don't seem to be using vanilla Safari because you have the privacy report button:
No. I am not using technology preview. Privacy Report button came with version 14.0.

1601388506957.png

It doesn't happen in the current XenForo website - 2.2.

It is surely weird.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.3).

Change log:
Prevent Safari from scrolling to the bottom of the page when autofocusing an input within a menu.
There may be a delay before changes are rolled out to the XenForo Community.
 
Top