1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Fatal error

Discussion in 'Troubleshooting and Problems' started by Piratebay, Nov 1, 2011.

  1. Piratebay

    Piratebay Member

    Whenever I visit my website I receive this error:
    Fatal error: Exception thrown without a stack frame in Unknown on line 0
    I cant' even go to the ACP.
    It worked just fine yesterday.
     
  2. Dodgeboard

    Dodgeboard Well-Known Member

  3. Piratebay

    Piratebay Member

    I tried to update the forum to 1.1 beta 4
    but now I have whole new errors:

    Server Error

    Mysqli prepare error: Table 'world153_xenforo.xf_data_registry' doesn't exist

    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Model/DataRegistry.php at line 64
    XenForo_Model_DataRegistry->_getFromDb() in XenForo/Model/DataRegistry.php at line 34
    XenForo_Model_DataRegistry->get() in XenForo/Application.php at line 595
    XenForo_Application->loadOptions() in XenForo/Application.php at line 777
    XenForo_Application->lazyLoad() in XenForo/Application.php at line 807
    XenForo_Application::get() in XenForo/Model/User.php at line 730
    XenForo_Model_User->getVisitingGuestUser() in XenForo/Visitor.php at line 390
    XenForo_Visitor::setup() in XenForo/Install/Controller/Upgrade.php at line 47
    XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 298
    XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 309
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/world153/public_html/install/index.php at line 18

    And yes, I deleted the lock file.
     
  4. borbole

    borbole Well-Known Member

    Can you check the database and see if the table reported as missing is indeed missing?

    P.s. When did you get that error btw, imemdiately when you ran the upgrader or at a later stage?
     
  5. Piratebay

    Piratebay Member

    I checked and it's indeed gone.
    And immediately after I tried to load the /install page
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It probably wasn't a good idea to try upgrading with an existing error.

    Did your host possibly do anything which could account for the error?
    Do you have any add-ons installed?

    You could try creating that table and running the upgrade script again though if all else fails.

    Code:
        CREATE TABLE xf_data_registry (
            data_key VARCHAR(25) NOT NULL PRIMARY KEY,
            data_value MEDIUMBLOB NOT NULL
        ) ENGINE = InnoDB CHARACTER SET utf8 COLLATE utf8_general_ci
     
    borbole likes this.
  7. borbole

    borbole Well-Known Member

    It is strange that a table should be dropped like that. Can you try to recreate the table as adviced above and then give the upgrade another go?

    P.s. Did you make a backup of the db before trying to upgrade your forum?
     
  8. Piratebay

    Piratebay Member

    My host told me they accidentally messed up some of the MySQL databases.
    I'll just completely re install the forum again, it's not a huge deal.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I had a feeling it had to be something like that.
     
  10. borbole

    borbole Well-Known Member

    If you have a backup of the database, pull only the data for that table and re-enter it at the database and then give the upgrade another go. No need to do a full re-install. That is if your host hasn''t messed up anything else.

    Anyway, good luck and let us know how it will go.
     

Share This Page