• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Fatal Error: Maximum function nesting level of '100' reached, aborting!

#1
In one of my posts, I've been using too much BB code, and as a result, an error has been thrown. So, I want to find out where I can increase this Maximum function nesting level, and I heard it's in php.ini. However, I don't know where this file is. I'm currently using WAMP to host my server on my home computer.
 

Brogan

XenForo moderator
Staff member
#2
If you are using WAMP, it will be something like C:\WAMP\PHP\php.ini

Basically wherever you have installed WAMP, in the PHP folder.
 
#3
I went to C:\WAMP\bin\php\php5.4.12\php.ini

There appears to be no "maximum function nesting level" however there is a Maximum_input_nesting_level hidden by comments (;). Could removed the ; (comments) and setting the max-input to say, 250 fix this error?
 

MattW

Well-known member
#4
If it's commented out, it will be using the default values. You can check what that currently is by looking at phpinfo via the ACP
upload_2014-4-3_20-59-20.png

Uncommenting and setting your own value, and restarting the webserver should sort it.
 
#5
I went in my Php files and changed the max_input_nesting_level to 150, but I still get an error saying the max is 100. I did remove the comment.
 

Mike

XenForo developer
Staff member
#8
Normally they're set via php.ini. There could be multiple ini files loaded (phpinfo would tell you where they are specifically). If you can't find a rule, you can just write a new line to increase it (or disable xdebug; the specifics of that would be controlled by WAMP).