1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Facebook 'recommend' button not appearing

Discussion in 'Troubleshooting and Problems' started by Derek Zeanah, Oct 18, 2016.

  1. Derek Zeanah

    Derek Zeanah Member

    Facebook integration is complete, and the test works, though this seems unrelated.

    Facebook integration is enabled in the control panel, and it appears like this when I view the page source:

    Code:
    <div class="section infoBlock sharePage">
    <div class="secondaryContent">
    <h3>Share This Page</h3>
    <div class="tweet shareControl">
    <a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal"
    data-lang="en-US"
    data-url="http://www.thehighroad.org/index.php"
    >Tweet</a>
    </div>
    <div class="facebookLike shareControl">
    <div class="fb-like" data-href="http://www.thehighroad.org/index.php" data-layout="button_count" data-action="recommend" data-font="trebuchet ms" data-colorscheme="0"></div>
    </div>
    <div class="plusone shareControl">
    <div class="g-plusone" data-size="medium" data-count="true" data-href="http://www.thehighroad.org/index.php"></div>
    </div>
    </div>
    </div>
    So it's trying to show. But none of my browsers on either of 2 machines (here and at my datacenter in another geographic location) see the box show up. I asked my users and they are seeing the same behavior - twitter and g+ buttons are there, but not the facebook recommend.

    upload_2016-10-18_15-21-0.png

    Disabling the feature eliminated the gap between the G+ and tweet buttons.

    I'm at a loss as to what the problem might be. Has anyone seen this before?
     
  2. Derek Zeanah

    Derek Zeanah Member

    I guess I'm the only one seeing this, then.
     
  3. Mike

    Mike XenForo Developer Staff Member

  4. Derek Zeanah

    Derek Zeanah Member

    I found the setting (not really a facebook user) and it looks like that's not it, as the settings were like this by default:

    upload_2016-10-21_4-29-21.png

    At least I know it's not Xenforo so I can poke around in more productive places. Thanks.
     

    Attached Files:

    Last edited: Oct 21, 2016
  5. Derek Zeanah

    Derek Zeanah Member

    The problem was resolved by going into Style Properties: General and choosing a Facebook Plugin Color Scheme. Neither had been selected.

    Once I chose one, the buttons started showing.
     
    Mike likes this.

Share This Page