1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Facebook login

Discussion in 'XenForo Questions and Support' started by Justin Kringstad, Nov 13, 2015.

  1. when i try to setup my account on my forums to login with facebook i'm getting this error:

    Invalid Scopes: publish_stream. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.facebook.com/docs/facebook-login/permissions

    is there something i havnt setup for this yet or is this a common error? i dont remember facebook login being this difficult
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds like your FB app is trying to access an invalid permission.
  3. Chris D

    Chris D XenForo Developer Staff Member

    Actually, if the prefix on this thread is correct, then you are likely going to need to upgrade XenForo to at least XenForo 1.3.0.

    There have been a number of changes to the Facebook API and as a result, there have been a number of updates in the XF code to support them. I can't guarantee that XF 1.3.0 will definitely work, but it certainly no longer asks for the publish_stream permission.
    Brogan likes this.
  4. yeah i got 1.2.9 so propably wont work till i upgrade my license then?
  5. Chris D

    Chris D XenForo Developer Staff Member

    Yeah, and if you do that, you'd be worthwhile going to 1.5.2 if possible - more features and more stable :)

Share This Page