XF 1.2 Facebook like - share from a thread

william1872

Member
Hey all,

I have a bit of a strange problem users of our community are reporting..

When the like a post within the forum it seems to share to facebook, however when they check their timeline, or one of their friends check their timeline the post doesn't appear?

However when I check their timeline I can see the post that has been shared, I can't for the life of me figure out is it something I've set wrong in the ACP or the Facebook application I setup for the connection?

I've attached a couple of images. Any help / advice appreciated?

William
 

Attachments

Brogan

XenForo moderator
Staff member
The post Like function is not linked with Facebook.

Are you sure it is the Like on posts they are clicking and not the link at the bottom of the page?
If so, it must be from an add-on or a modification.
 

william1872

Member
problem solved (my error) looks like when the facebook app was created it defaulted to sandbox mode, although I could see the posts none of the people sharing the posts could...
 

Brogan

XenForo moderator
Staff member
Ah, interesting.
Thanks for posting that, it will be useful in the future if anyone else encounters the same problem.
 

Mouth

Well-known member
problem solved (my error) looks like when the facebook app was created it defaulted to sandbox mode, although I could see the posts none of the people sharing the posts could...
For prosperity, it would be good to let people know where you found this setting to be able to change it?
 

william1872

Member
Thanks Brogan : )

Sure thing guys here's a screenshot -- It's not an obvious setting and took me a while to find it

"Do you want to make this app and all its live features available to the general public?"

Enable this option and that disables Sandbox mode. The setting is in Settings & Review

: )Xenforo fb app sandbox image.png
 
Top