1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook and Twitter Login Buttons to Sidebar Visitor Panel [Deleted]

Discussion in 'Template Modifications' started by DRE, Mar 10, 2012.

  1. DRE

    DRE Well-Known Member

    The8thLegion submitted a new resource:

    Facebook and Twitter Login Buttons to Sidebar Visitor Panel (version 1.0) - Facebook and Twitter Login Buttons

    Read more about this resource...
  2. Dev

    Dev Member

    I tried this but only Facebook button is showing up. twitter button is not showing..
  3. drawmonster

    drawmonster New Member

    Same here.
  4. DRE

    DRE Well-Known Member

    K I'll investigate later today. I will reinstall twitter fresh on my other site to see what the problem is.
  5. bambua

    bambua Well-Known Member

    Center html tag is depreciated and really doesn't render well in some browsers. It will also stop an xf site from validating if that's important to the owner.

    check out: http://www.codehelp.co.uk/html/deprecated.html if you need some help replacing that.
  6. Rho Delta

    Rho Delta Well-Known Member

    Only the facebook button shows up.
  7. DRE

    DRE Well-Known Member

    This resource has been removed and is no longer available for download.
  8. DRE

    DRE Well-Known Member

    sorry guys but i don't know why it doesn't work for you or have the time to troubleshoot it so i deleted it.
  9. Rho Delta

    Rho Delta Well-Known Member

    Can you make it available for someone else to work on? This would be a great feature if it worked properly!

    Also can you provide the code so I can uninstall it for now?
  10. Brogan

    Brogan XenForo Moderator Staff Member

  11. DRE

    DRE Well-Known Member

    I shouldn't have deleted the resource my bad. I'd un-delete it if I could.
    I think it doesn't work for them because I pointed them to a twitter login that may not be the one I'm using. There were four different twitter authentication addons posted on here. The first one sucked. The second worked for awhile. Then a guy in the thread uploaded his own version which worked fine and then another guy uploaded a different version in resources.
  12. Rho Delta

    Rho Delta Well-Known Member

    I didn't write down what the template modifications were... do you have them saved so I can remove them?
  13. mjp

    mjp Well-Known Member

    Remove this from sidebar_visitor_panel:
    <center><xen:if is="{$xenOptions.facebookAppId}">
                        <xen:require css="facebook.css" />
                        <li><a href="{xen:link register/facebook, '', 'reg=1'}" class="fbLogin" tabindex="110"><span>{xen:phrase login_with_facebook}</span></a></li>
    <xen:if is="{$xenOptions.c2Twitter_consumerKey}">
    <div class="cta_twButton">
    <a href="{xen:link register/twitter, '', 'reg=1'}" class="twLogin"><img src="http://a0.twimg.com/images/dev/buttons/sign-in-with-twitter-d.png" alt="Sign up with Twitter" /></a>
    Remove this from extra.css:
    /* Add Twitter login button to visitor panel */
    .cta_twButton {
    margin: 10px 30px;
    text-align: center;
  14. DRE

    DRE Well-Known Member

    Twitter Authentication
  15. DRE

    DRE Well-Known Member

  16. Rho Delta

    Rho Delta Well-Known Member

    Any way you can change the code to work with the one currently in the resource center? I think I had the one you are using before and deleted it to install the current resource center one. The new one works fine.
  17. DRE

    DRE Well-Known Member

    Sure. I'm trying to get xampp working on my computer first so that I can use another xenforo installation to test out modifications and skins without messing up my own live sites. When I'm done with that I'll add all my old resources and skins to the resource manager too.
    The Pet Board likes this.

Share This Page