XF 1.4 External Redirect / Porn Spamming?

#1
Hello.

We've noticed that we are getting loads (and I mean loads!) of backlinks from porn sites recently and they seem to be using our External Redirect proxy to do it. I don't know why or how....here is an example:

https://www.gravyforthebrain.com/xenforo/proxy.php?link=http://2beeg.mobi

This happens even if users are not logged in. Is there any way I can stop this external redirect from working/happening, and has anyone else seen anything like this? We've done a malware search but come up with nothing, and in the above example, '2beeg' doesn't appear anywhere in our db.....

Would really appreciate some advice on this one!

Thanks!

Hugh.
 

Mike

XenForo developer
Staff member
#2
Since you've tagged this as 1.4, I don't recall when we changed the approach of the link proxy, but I think it may have been after this version. In newer versions, it doesn't try to interject any URLs in the middle when a link is clicked, so there's never any reason to have the link redirection page displayed. (In 1.4, there may be some edge cases that could trigger it.)

However, if you want, you can empty the link_redirect template contents which will prevent any URL like that from working.
 
#3
Hi Mike,

Thanks for the reply. I guess that spawns two further questions from me! Firstly, if I upgrade the installation to V2 will it solve this problem, and secondly, how do I empty the link_redirect template?
 

Mike

XenForo developer
Staff member
#4
By newer versions, I was referring to 1.5 specifically -- 2.0 is still in beta so we don't recommend running it in production. (It's also a much bigger update.)

You can go into the templates section of the control panel, search for "link_redirect" and empty the contents of the template.
 
#5
Hi Mike,

So I emptied the contents of the link_redirect template and it didn't work - we still have loads. I looked at the view custom changes link at the bottom which had this in it, but which it won't let me delete:
-------
<xen:title>{xen:phrase external_redirect}</xen:title>

<div class="sectionMain">
<div class="primaryContent">
<p style="margin-bottom: 1em">{$printable}</p>

<p>{xen:phrase you_about_to_leave_x_and_visit_site_no_control, 'board={$xenOptions.boardTitle}', 'host={$parts.host}'}</p>
</div>
<div class="secondaryContent">
<a href="{$url}" rel="nowfollow" class="button primary">{xen:phrase continue}...</a>
</div>
</div>
-------

Any ideas? I don't mind upgrading to the latest version of V1 if that will help, but the Xenforo Bridge software I use for Wordpress isn't yet complint with V2 so I can't go that far.....
 
Top