1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Everyone is administrator after import

Discussion in 'Troubleshooting and Problems' started by Moi EtOuir, Sep 9, 2011.

  1. Moi EtOuir

    Moi EtOuir New Member

    Hi,

    I got a new problem... I imported a myBB to vBulletin then to Xenforo

    But the permissions and groups were not right, so I deleted every groups that I made with myBB (thinking that it would set every users to Registered)
    But instead, it set everyone to the Administrative group

    Is there a SQL query that I can run to fix this ? Or a tool maybe... :/
     
  2. Slavik

    Slavik XenForo Moderator Staff Member

    UPDATE `xf_user` SET `user_group_id` = '1'

    Change '1' to whatever you "registered" usergroup ID is from the xf_user_group table

    Then change your admin account back to the admin usergroup.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The Registered group is always id 2. The group might have been renamed, but it's always 2. Administrative is id 3. Check the ids.

    Deleting a group will move those users into the default Registered group (id 2). It should not have made them admins. Where are you seeing the admin status? Is it their user title perhaps?

    That doesn't work, per Mike's post. He corrected me when I tried it.
     
    Moi EtOuir likes this.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Just to add a bit more explanation, being a member of a user group does not make a member an administrator (or moderator).
    It is for user group mark up and permissions only.

    They have to explicitly be made an administrator (or moderator).

    If you haven't already done so, I would recommend reading through the Help Manual: http://xenforo.com/help/manual/
     
    Moi EtOuir likes this.

Share This Page