1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Import from vB Permission issues

Discussion in 'Installation, Upgrade, and Import Support' started by StoveBolts, Oct 11, 2013.

  1. StoveBolts

    StoveBolts Member

    Alright, we've got some issue going on that I'm having a hard time fixing.
    1. http://xenforo.com/help/user-group-promotions/ We have some users that every post is in moderation. Others are fine. Some are new xenforo members, some are old vBulletin users that were ported over.
    2. Administrative and Super Administrator gets a permissions denied when trying to access reports.

    We have almost 6,000 users and 650,000 posts we migrated from vB to xenforo. Here is the history.
    Several years ago the site was migrated from phpbb to vBulletin. It was a sloppy migration with little care. While in vB, many custom user groups / permissions were created. xenforo did it's best to import everything, but I found when it couldn't decipher the groups, it did nothing.

    Problem 1. Certain users and new users get stuck in moderation when user group promotion is implemented.

    One of the first things I noticed was it brought all of our existing moderators in as native xenforo Super Moderators.

    This is where I found my first anomaly. I moved all of our moderators from the special groups we created in vB and placed them all in the Moderating group. We have a "Moderator" forum that isn't visible to the pubic, so I added all the permissions (view node etc) for that forum for the moderating group. However, they still couldn't see it. It wasn't until I added the old groups to the forum that they were able to view the forum. I created a test user, added it to the moderating group and it was fine. So I asked, "Why don't they see it? Both test user and Moderating user have the same permissions and belong to the same group.

    Looking at the database through phpmyadmin, I did a compare from an imported moderator and my new test moderator. Both lined up perfectly except permission_combination_id (Which you can't see or change from the admincp). I changed our moderators permission_combination_id to the same as my test moderator and they could then see the forum.

    I then looked at our user base and we had users in several different custom groups created in vB. It made it really hard to manage so I decided to move everyone into the xenforo 'Registered" group. This worked well, but we started seeing oddities right off the bat. Long story short, it was permission_combination_id again. So I did a compare with a test user I created and did a mass update on permission_combination_id and wha-la, out of almost 6000 users, it changed 1,832 users and it fixed some major problems with many of our users, but not the promoted users problem.

    Where we are at now: Every time I set the registered user group per the user-group-promotions tutorial, all new members and a hand full of old members get stuck in the moderation queue for every post while others are completely unaffected.

    Problem 2. Administrative and Super admin recieve Permissions denied when trying to access reports page.

    So here's what happened. Because our moderators were having issues like not being able to edit their own profiles etc, sometimes getting errors when reporting posts etc, I removed every one of them from the Super Moderator group. I then demoted them to "Registered". I also did this for our three "Administrative" ids'.

    Under tools in the admincp, I used the option to delete unused permissions.
    I then added all of our mods to the Moderating group, and then assigned them their forums. This resolved all of their issues (thank goodness).

    However, it created an issue for the Administrative group. Now all of the Super Admins and all three ids' in the Administrative group no longer have permissions to view reports. We get a "Permissions denied" page.

    Before I do anything else, I thought it best to come here first for any suggestions.

  2. StoveBolts

    StoveBolts Member

    Alright, don't ask me why this worked, but it did...

    For the Administrative group, I went into the table xf_users table and manually set is_moderator to 1 for my administrative account.
    I no longer receive the "Permissions denied" when trying to view the reports and I get the nifty little icon in the top right corner for reports.

    The way I figured this out is I have a test id that I created in xF. I put the user in the moderating group and that user could not see the reports tab. I looked in the xf_user table and is_moderator was set to 0. I checked a moderator who was a-ok and they were set to 1. Thus, I set my test id to match a known working user and it worked.

    My question is this. Why did I have to manually add a 1 for my test id in the is_moderated field? Is this because I manually added the test user to the moderating group through the find user function and used the drop down list to set his primary group to moderating? If I would had used the add moderator wizard, would this have put the 1 in the is_moderator column? If so, I would ask that you remove the moderating user group from the list for future admins.

    As well, why doesn't the is_admin = 1 allow access to the reports?

  3. Brogan

    Brogan XenForo Moderator Staff Member

    Adminstrators are not moderators.

    You need to explicitly make members moderators to afford them the various moderator functions.
    The moderating user group can be used to set base permissions and for styling.

    As for your other issues, permissions do need to be reviewed and sometimes changed after importing.
  4. StoveBolts

    StoveBolts Member

    Thanks Brogan, I appreciate your quick response as always.

    By explicitly, I take it you mean I should use the wizard, "Add Moderator" "Add Administrator" and not simply search for a user and change their primary group from registered to Moderator or Administrative since manually adding them from the drop down list box does not generate any code (that I suspect the wizard does) to add the required 1 for "is_moderator" in the xf_user table which is required for certain moderator functions such as the reports tab. Ok, deep breath lol! I hope I articulated that ok ha ha!

    If what I've found is the case, then maybe on release 1.2.3 you guys can remove the moderating and Administrative groups from the drop down list box (or add a pop up saying they won't have full moderating or adminstrative rights using that method) so others won't have the same issue I'm having.

    As far as my other issue with the users getting stuck in moderation every time I try to use promote users from your supplied url, I'm finding that they all have the value 2 in common for their permission_combination_id field. I'm trying to map that all out so I can figure out what in the heck all those values mean and how they are used. I'm thinking about changing my test user to a value for a member that I know is working ok when I turn on user promotions and seeing if that helps. I did a quick query on the database and out of 6000 users, I found 1,600 with the value of 2.

    Anyway you can get me into contact with one of your developers to help me map this out? That way I'm not just guessing and making mass changes to the database. I suspect the over 1600 users that were returned were part of the 1,832 users that were hit last time I had to do the mass update through sql. I suspect this because I see a lot of the same user names from both lists.

    As a side note, our staff and members are really liking xenforo. It rocks! I can't wait to get these bugs out of her so we can really start expanding it.

Share This Page