Fixed ES 2.0 issue

Affected version


Active member
It worked a while after the upgrade, but when I tried to configure it to support https, it wouldn't work, and eventually got hosed. Now when I select the Enhanced Search option from the left menu, I get the following error:

XFES\Elasticsearch\RequestException: Unknown error in src/addons/XFES/Elasticsearch/Api.php at line 375
  1. XFES\Elasticsearch\Api->request() in src/addons/XFES/Elasticsearch/Api.php at line 244
  2. XFES\Elasticsearch\Api->getIndexInfo() in src/addons/XFES/Service/Analyzer.php at line 118
  3. XFES\Service\Analyzer->getCurrentConfig() in src/addons/XFES/Admin/Controller/EnhancedSearch.php at line 44
  4. XFES\Admin\Controller\EnhancedSearch->actionIndex() in src/XF/Mvc/Dispatcher.php at line 249
  5. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  6. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  7. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1879
  8. XF\App->run() in src/XF.php at line 328
  9. XF::runApp() in admin.php at line 13


Active member
i was able to revert back to original settings, so the errors are gone - but would like to enable the https option. will work at it.


XenForo developer
Staff member
I have to guess that something changed outside of XF if it worked for a while. However, I have made some changes to prevent this error, as it should allow you to get into this page and reconfigure your index if needed.