XF 2.2 Errors in ACP: source and fix?

djbaxter

Well-known member
XF 2.2.7
PHP 7.3.30

I am getting repeated errors just like this:

Code:
    ErrorException: Template error: [E_WARNING] include(): Failed opening '/home/{account}/domains/{domain}/public_html/internal_data/code_cache/phrase_groups/l1/custom_bb_code_output.php' for inclusion (include_path='.:/usr/local/php73/lib/php') src/XF/Language.php:287

    Generated by: Unknown account Sep 23, 2021 at 3:40 AM

Stack trace

#0 src/XF/Language.php(287): XF\Template\Templater->handleTemplateError(2, '[E_WARNING] inc...', '/home/{account}/...', 287, Array)
#1 src/XF/Language.php(287): include()
#2 src/XF/Language.php(249): XF\Language->loadPhraseGroup('custom_bb_code_...')
#3 src/XF/Language.php(132): XF\Language->getPhraseText('custom_bb_code_...')
#4 src/XF/Phrase.php(54): XF\Language->renderPhrase('custom_bb_code_...', Array, 'html', Array)
#5 src/XF/Phrase.php(61): XF\Phrase->render()
#6 src/XF/Template/Templater.php(5120): XF\Phrase->__toString()
#7 src/XF/Template/Templater.php(1158): XF\Template\Templater->testEmpty(Object(SV\StandardLib\XF\Template\Templater), Object(XF\Phrase))
#8 internal_data/code_cache/templates/l1/s10/public/_help_page_bb_codes.php(307): XF\Template\Templater->test(Object(XF\Phrase), 'empty', Array)
#9 src/XF/Template/Templater.php(1651): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#10 src/XF/Mvc/View.php(61): XF\Template\Templater->renderTemplate('_help_page_bb_c...', Array)
#11 src/XF/Pub/View/Help/Page.php(11): XF\Mvc\View->renderTemplate('public:_help_pa...', Array)
#12 src/XF/Mvc/Renderer/AbstractRenderer.php(91): XF\Pub\View\Help\Page->renderHtml()
#13 src/XF/Mvc/Renderer/Html.php(47): XF\Mvc\Renderer\AbstractRenderer->renderViewObject('XF:Help\\Page', 'public:help_pag...', Array)
#14 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Help\\Page', 'public:help_pag...', Array)
#15 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#16 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#17 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#18 src/XF/App.php(2345): XF\Mvc\Dispatcher->run()
#19 src/XF.php(512): XF\App->run()
#20 index.php(20): XF::runApp('XF\\Pub\\App')
#21 {main}

Request state

array(4) {
  ["url"] => string(15) "/help/bb-codes/"
  ["referrer"] => bool(false)
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

alternating with this:

Code:
Server error log

    ErrorException: Template error: [E_WARNING] include(/home/{account}/domains/{domain}/public_html/internal_data/code_cache/phrase_groups/l1/custom_bb_code_output.php): failed to open stream: No such file or directory src/XF/Language.php:287 

    Generated by: Unknown account Sep 23, 2021 at 3:40 AM 

Stack trace

#0 src/XF/Language.php(287): XF\Template\Templater->handleTemplateError(2, '[E_WARNING] inc...', '/home/{account}/...', 287, Array)
#1 src/XF/Language.php(287): include()
#2 src/XF/Language.php(249): XF\Language->loadPhraseGroup('custom_bb_code_...')
#3 src/XF/Language.php(132): XF\Language->getPhraseText('custom_bb_code_...')
#4 src/XF/Phrase.php(54): XF\Language->renderPhrase('custom_bb_code_...', Array, 'html', Array)
#5 src/XF/Phrase.php(61): XF\Phrase->render()
#6 src/XF/Template/Templater.php(5120): XF\Phrase->__toString()
#7 src/XF/Template/Templater.php(1158): XF\Template\Templater->testEmpty(Object(SV\StandardLib\XF\Template\Templater), Object(XF\Phrase))
#8 internal_data/code_cache/templates/l1/s10/public/_help_page_bb_codes.php(307): XF\Template\Templater->test(Object(XF\Phrase), 'empty', Array)
#9 src/XF/Template/Templater.php(1651): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#10 src/XF/Mvc/View.php(61): XF\Template\Templater->renderTemplate('_help_page_bb_c...', Array)
#11 src/XF/Pub/View/Help/Page.php(11): XF\Mvc\View->renderTemplate('public:_help_pa...', Array)
#12 src/XF/Mvc/Renderer/AbstractRenderer.php(91): XF\Pub\View\Help\Page->renderHtml()
#13 src/XF/Mvc/Renderer/Html.php(47): XF\Mvc\Renderer\AbstractRenderer->renderViewObject('XF:Help\\Page', 'public:help_pag...', Array)
#14 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Help\\Page', 'public:help_pag...', Array)
#15 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#16 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#17 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#18 src/XF/App.php(2345): XF\Mvc\Dispatcher->run()
#19 src/XF.php(512): XF\App->run()
#20 index.php(20): XF::runApp('XF\\Pub\\App')
#21 {main}

Request state

array(4) {
  ["url"] => string(15) "/help/bb-codes/"
  ["referrer"] => bool(false)
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

Any ideas as to what's causing this and how to fix it?
 

carsafety

Member
Also have been receiving these exact same template errors in sets of four, at least a few times a day since updating to 2.2.7. Running PHP 7.4.24. Pretty stock Xenforo with two addons, Litespeed and Siropu Ads Manager.
 
Top