1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ErrorException: Undefined property: stdClass::$fields

Discussion in 'Enhanced Search Support' started by CyclingTribe, Aug 3, 2012.

  1. CyclingTribe

    CyclingTribe Well-Known Member

    Code:
    ErrorException: Undefined property: stdClass::$fields - library/XenES/Search/SourceHandler/ElasticSearch.php:314
    Generated By: user, Wednesday at 15:21
    Stack Trace
    
    #0 /library/XenES/Search/SourceHandler/ElasticSearch.php(314): XenForo_Application::handlePhpError(Array, Array, Array, Array, 300, Object(XenForo_Search_DataHandler_Post))
    #1 /library/XenES/Search/SourceHandler/ElasticSearch.php(211): XenES_Search_SourceHandler_ElasticSearch->_getSqlLimitedHits('helmet', true, Array, Array, '', '300', Object(XenForo_Search_DataHandler_Post))
    #2 /library/XenForo/Search/SourceHandler/Abstract.php(152): XenES_Search_SourceHandler_ElasticSearch->executeSearch(Object(XenForo_Search_DataHandler_Post), 'helmet', Array, 'replies', 0, '300')
    #3 /library/XenForo/Search/Searcher.php(111): XenForo_Search_SourceHandler_Abstract->searchType(Object(XenForo_Search_DataHandler_Post), 'helmet', Array, 'replies', 0)
    #4 /library/XenForo/ControllerPublic/Search.php(224): XenForo_Search_Searcher->searchType()
    #5 /library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Search->actionSearch(Object(XenForo_RouteMatch))
    #6 /library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch()
    #7 /index.php(13): XenForo_FrontController->run()
    #8 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(38) "http://www.cyclechat.net/search/search"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(13) {
        ["keywords"] => string(6) "helmet"
        ["title_only"] => string(1) "1"
        ["users"] => string(0) ""
        ["date"] => string(0) ""
        ["reply_count"] => string(1) "0"
        ["prefixes"] => array(1) {
          [0] => string(0) ""
        }
        ["nodes"] => array(1) {
          [0] => string(0) ""
        }
        ["order"] => string(7) "replies"
        ["type"] => string(4) "post"
        ["_xfToken"] => string(57) "22551,1343830846,01a252517c90fd89c6544580e8f1199736d9af25"
        ["_xfRequestUri"] => string(18) "/search/?type=post"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    Any idea what this error is? and what's causing it?
     
  2. Slavik

    Slavik XenForo Moderator Staff Member

    Anything been updated / installed recently?
     
  3. CyclingTribe

    CyclingTribe Well-Known Member

    No, nothing at all.

    NB: This is for my biggest/busiest site - CycleChat.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    I've just done some searches on your forum. Seems related to whenever the results are ordered by "most replies".

    It searches fine on other options.
     
  5. Slavik

    Slavik XenForo Moderator Staff Member

    Was just testing this and yes, confirmed, cannot seem to replicate the error elsewhere though.
     
  6. CyclingTribe

    CyclingTribe Well-Known Member

    Thanks guys. So is this an issue with my site or with ES?
     
  7. Slavik

    Slavik XenForo Moderator Staff Member

    Would apear to be limited to your site. Does the ES log show up anything?
     

Share This Page