Server issue ErrorException: getimagesize(): Read error!

rdn

Well-known member
Full Error Log:

Code:
Server Error Log

Error Info
ErrorException: getimagesize(): Read error! - library/XenGallery/Helper/Image.php:84
Generated By: Unknown Account, Today at 1:57 AM

Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(8, 'getimagesize():...', '/home/nginx/dom...', 84, Array)
#1 /library/XenGallery/Helper/Image.php(84): getimagesize('/home/nginx/dom...')
#2 /library/XenGallery/Helper/Image.php(132): XenGallery_Helper_Image->_readImageInfo()
#3 /library/XenGallery/Helper/Image.php(837): XenGallery_Helper_Image->_setNewMainImage('/home/nginx/dom...')
#4 /library/XenGallery/Thumbnail/Abstract.php(57): XenGallery_Helper_Image->save('youtube_ni-ve2f...', 'data/xengallery...', 'jpg')
#5 /library/XenGallery/Model/Media.php(3171): XenGallery_Thumbnail_Abstract::saveThumbnailFromPath('youtube', 'ni-ve2fojSQ', '/home/nginx/dom...')
#6 /library/XenGallery/Model/Media.php(1005): XenGallery_Model_Media->getVideoThumbnailUrlFromParts(Array)
#7 /library/XenGallery/Model/Media.php(1068): XenGallery_Model_Media->prepareMedia(Array)
#8 /library/XenGallery/ControllerPublic/Media.php(46): XenGallery_Model_Media->prepareMediaItems(Array)
#9 /library/XenForo/FrontController.php(347): XenGallery_ControllerPublic_Media->actionIndex()
#10 /library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /index.php(13): XenForo_FrontController->run()
#12 {main}

Request State
array(3) {
  ["url"] => string(30) "http://www.phcorner.net/media/"
  ["_GET"] => array(1) {
    ["/media/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 

Mike

XenForo developer
Staff member
Did this happen just once or multiple times?

The read error generally happens if PHP itself fails to read from the stream of data (as in it failed unexpectedly). It may have indicated a temporary blip in the server rather than anything else.
 

rdn

Well-known member
Encounter twice today.
Code:
Error Info
ErrorException: getimagesize(): Read error! - library/XenGallery/Helper/Image.php:84
Generated By: maxine-is-my-love, Today at 7:19 AM

Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(8, 'getimagesize():...', '/home/nginx/dom...', 84, Array)
#1 /library/XenGallery/Helper/Image.php(84): getimagesize('data/xengallery...')
#2 /library/XenGallery/Helper/Image.php(54): XenGallery_Helper_Image->_readImageInfo()
#3 /library/XenGallery/Thumbnail/Abstract.php(54): XenGallery_Helper_Image->__construct('data/xengallery...')
#4 /library/XenGallery/Model/Media.php(3171): XenGallery_Thumbnail_Abstract::saveThumbnailFromPath('youtube', '6qmiv7iEubk', '/home/nginx/dom...')
#5 /library/XenGallery/Model/Media.php(1005): XenGallery_Model_Media->getVideoThumbnailUrlFromParts(Array)
#6 /library/XenGallery/Model/Media.php(1068): XenGallery_Model_Media->prepareMedia(Array)
#7 /library/XenGallery/ControllerPublic/Media.php(46): XenGallery_Model_Media->prepareMediaItems(Array)
#8 /library/XenForo/FrontController.php(347): XenGallery_ControllerPublic_Media->actionIndex()
#9 /library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /index.php(13): XenForo_FrontController->run()
#11 {main}

Request State
array(3) {
  ["url"] => string(30) "http://www.phcorner.net/media/"
  ["_GET"] => array(1) {
    ["/media/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
Code:
Error Info
ErrorException: getimagesize(): Read error! - library/XenGallery/Helper/Image.php:84
Generated By: maxine-is-my-love, Today at 7:19 AM

Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(8, 'getimagesize():...', '/home/nginx/dom...', 84, Array)
#1 /library/XenGallery/Helper/Image.php(84): getimagesize('/home/nginx/dom...')
#2 /library/XenGallery/Helper/Image.php(132): XenGallery_Helper_Image->_readImageInfo()
#3 /library/XenGallery/Helper/Image.php(837): XenGallery_Helper_Image->_setNewMainImage('/home/nginx/dom...')
#4 /library/XenGallery/Thumbnail/Abstract.php(57): XenGallery_Helper_Image->save('youtube_BfxzcJo...', 'data/xengallery...', 'jpg')
#5 /library/XenGallery/Model/Media.php(3171): XenGallery_Thumbnail_Abstract::saveThumbnailFromPath('youtube', 'BfxzcJo58rE', '/home/nginx/dom...')
#6 /library/XenGallery/Model/Media.php(1005): XenGallery_Model_Media->getVideoThumbnailUrlFromParts(Array)
#7 /library/XenGallery/Model/Media.php(1068): XenGallery_Model_Media->prepareMedia(Array)
#8 /library/XenGallery/ControllerPublic/Media.php(46): XenGallery_Model_Media->prepareMediaItems(Array)
#9 /library/XenForo/FrontController.php(347): XenGallery_ControllerPublic_Media->actionIndex()
#10 /library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /index.php(13): XenForo_FrontController->run()
#12 {main}

Request State
array(3) {
  ["url"] => string(30) "http://www.phcorner.net/media/"
  ["_GET"] => array(1) {
    ["/media/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 

Mike

XenForo developer
Staff member
Unfortunately this really just seems like a server issue if reading from the underlying storage itself is failing (which is what triggers this error).
 
Top