XF 2.2 Error when upgrading to 2.2.8: Class 'DOMDocument' not found

brunoa

Member
After uploading the files and running php cmd.php xf:upgrade on command line, I get this error. My server passed the requirements test though.

Need an urgent solution as the forum is currently down... thanks!

XenForo® 2 system requirements test​

Requirements met
Your server meets all of XenForo's PHP requirements.


Current version: 2020871
Upgrade target: 2020871 (2.2.8 Patch 1)
You are already running the latest version. Rebuild the master data? [y/n] y

In Xml.php line 33:

Class 'DOMDocument' not found
 

brunoa

Member
Problem solved. Had to finish the installation through the web browser, by going to the forum url /install, after completing the first part through command line.

It finished rebuilding the master data in 5 minutes or so and the forum automatically reopened.
 
Top