1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Error When Signing Up For Forums

Discussion in 'Troubleshooting and Problems' started by ViciousGnome, Feb 27, 2015.

  1. ViciousGnome

    ViciousGnome Active Member

    Hello, and thank you for trying to assist me.

    A friend of mine tried to sign up in my forums today, and told me he received an error. I have been signing into the forums and using them for a while without any problems. I opened a new browser (Opera) and tried to sign up. I was unable to, and received the following error message:

    I'm Just A Cop... - Error
    A server error occurred. Please try again later.

    I recently upgraded to the latest version of xenForo, but I have no idea how long this problem has persisted. Any help would be appreciated. Thank you.

    My forums are here: http://imjustacop.com/forums/index.php
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is there anything in the ACP error log?

    Also check the server error log.
  3. ViciousGnome

    ViciousGnome Active Member

    Will do Brogan. Checking now.
  4. ViciousGnome

    ViciousGnome Active Member

    Brogan, I have 14 errors in the Serror Error Logs. What would I be looking for? This seems to be the error related to my friend signing up because I saw his name and email address. I blocked out his email address, but here is the rest:

    Zend_Http_Client_Exception: Unable to load adapter 'Zend_Http_Client_Adapter_Socket': File "Zend/Http/Client/Adapter/Socket.php" does not exist or class "Zend_Http_Client_Adapter_Socket" was not found in the file - library/Zend/Http/Client.php:844
    Generated By: Unknown Account, Today at 10:42 AM
    Stack Trace
    #0 /users/imjustacop.com/htdocs/forums/library/Zend/Http/Client.php(941): Zend_Http_Client->setAdapter('Zend_Http_Clien...')
    #1 /users/imjustacop.com/htdocs/forums/library/XenForo/Captcha/KeyCaptcha.php(74): Zend_Http_Client->request('GET')
    #2 /users/imjustacop.com/htdocs/forums/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_KeyCaptcha->isValid(Array)
    #3 /users/imjustacop.com/htdocs/forums/library/XenForo/ControllerPublic/Register.php(355): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
    #4 /users/imjustacop.com/htdocs/forums/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
    #5 /users/imjustacop.com/htdocs/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /users/imjustacop.com/htdocs/forums/index.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
      ["url"] => string(56) "http://imjustacop.com/forums/index.php?register/register"
      ["_GET"] => array(1) {
        ["register/register"] => string(0) ""
      ["_POST"] => array(15) {
        ["username"] => string(0) ""
        ["a1a64e71e845320eb14b27bdc8e22684"] => string(7) "Shawn K"
        ["5bee82dad8d998ec1351ca5e712af9a2"] => string(22) "BLOCKED OUT EMAIL ADDRESS"
        ["b4230a24ebec44a35ab2062a3a445e47"] => string(4) "male"
        ["dob_month"] => string(2) "11"
        ["dob_day"] => string(1) "7"
        ["dob_year"] => string(4) "1987"
        ["location"] => string(5) "40203"
        ["6a379e23e1298410d978e267f1e35ce8"] => array(1) {
          ["yzm2zjjhzte3mdkyoq"] => string(0) ""
        ["custom_fields_shown"] => array(1) {
          [0] => string(18) "yzm2zjjhzte3mdkyoq"
        ["e38c2b89c8228041913a16ef8fc40a14"] => string(16) "America/New_York"
        ["keycaptcha_code"] => string(172) "1da2e5af2f780faa83180a65122650dc|fdbd09308c6b03c5b7a848eb0ed37a76|http://back15.keycaptcha.com/swfs/ckc/de2f467935462a7b91af073b615cda03-|bd5038c7b8760e1688692ad9b6c945ba|1"
        ["agree"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["reg_key"] => string(32) "c36f2ae170929868c6cfd6a34e255075"
  5. ViciousGnome

    ViciousGnome Active Member

    I checked the Server Error Log, where is ACP error log?
  6. Amaury

    Amaury Well-Known Member

    Admin CP > Tools > Server Error Logs

    There should also be a notice of server errors on the front page of the ACP.
  7. ViciousGnome

    ViciousGnome Active Member

    Thank you. I believe the above listed error is the one that is blocking users from registering in my forums.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Has anything changed on the server recently?

    The error could indicate a problem with some of the files.

    Try uploading the /library/Zend/Http folder again.
  9. ViciousGnome

    ViciousGnome Active Member

    Not to my knowledge Brogan. I will upload that folder again just to be safe. I will then try to register again, and let you know how it works out.
  10. ViciousGnome

    ViciousGnome Active Member

    I uploaded the /library/Zend/Http folder, and it appears to be working. If anyone tries to register and can not, please let me know, but I was just successful in registering a new account. Thank you for your help.

Share This Page