1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Error Uploading Files

Discussion in 'Troubleshooting and Problems' started by Yoshi910, Nov 18, 2012.

  1. Yoshi910

    Yoshi910 Member

    Whenever someone tries to upload a file though the forums, they get the following error:
    [​IMG]

    In the server error logs:

    Error Info:
    Code:
    ErrorException: move_uploaded_file(/home/********/public_html/internal_data/attachments/0/369-6de1c9bc784766464cc4a89001bbdd47.data) [<a href='function.move-uploaded-file'>function.move-uploaded-file</a>]: failed to open stream: Permission denied - library/XenForo/DataWriter/AttachmentData.php:203
    Generated By: Yoshi910, 1 minute ago
    Stack Trace:
    Code:
    #0 [internal function]: XenForo_Application::handlePhpError('/tmp/phpDSbH1l', '/home/yoshi910/...')
    #1 /home/********/public_html/library/XenForo/DataWriter/AttachmentData.php(203): move_uploaded_file('/tmp/phpDSbH1l', '/home/yoshi910/...')
    #2 /home/********/public_html/library/XenForo/DataWriter/AttachmentData.php(183): XenForo_DataWriter_AttachmentData->_moveFile('/tmp/phpDSbH1l', Array)
    #3 /home/********/public_html/library/XenForo/DataWriter/AttachmentData.php(117): XenForo_DataWriter_AttachmentData->_writeAttachmentFile()
    #4 /home/********/public_html/library/XenForo/DataWriter.php(1385): XenForo_DataWriter_AttachmentData->_postSave()
    #5 /home/********/public_html/library/XenForo/Model/Attachment.php(488): XenForo_DataWriter->save(Object(XenForo_Upload), 1)
    #6 /home/********/public_html/library/XenForo/ControllerPublic/Attachment.php(195): XenForo_Model_Attachment->insertUploadedAttachmentData()
    #7 /home/********/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Attachment->actionDoUpload(Object(XenForo_RouteMatch))
    #8 /home/********/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch()
    #9 /home/********/public_html/index.php(13): XenForo_FrontController->run()
    #10 {main}
    Request State:
    Code:
    array(3) {
      ["url"] => string(107) "http://blizzardcraft.com/attachments/do-upload.json?hash=50b372aac0d45401fff9700d218b78a&content_type=post"
      ["_GET"] => array(2) {
        ["hash"] => string(32) "50b372aac0d45401fff9700d218b78a"
        ["content_type"] => string(4) "post"
      }
      ["_POST"] => array(7) {
        ["Filename"] => string(11) "Capture.PNG"
        ["_xfToken"] => string(53) "1,1353205546,d87e1487960d218ace09abfa700d218a294073ed"
        ["_xfSessionId"] => string(32) "ac1dbe90c033171f700d218daf0208e65a"
        ["_xfResponseType"] => string(4) "json"
        ["_xfNoRedirect"] => string(1) "1"
        ["content_data"] => array(1) {
          ["node_id"] => string(2) "34"
        }
        ["Upload"] => string(12) "Submit Query"
      }
    }
     
  2. MattW

    MattW Well-Known Member

    Is the directory the images are stored in writable (chmod 755 or 777)?
     
    Jake Bunce likes this.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    data and internal_data should be fully writable (chmod 777, or maybe 755 depending on your server config).
     

Share This Page