1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error Uploading Avatar

Discussion in 'XenForo Questions and Support' started by OakleyForum, May 3, 2013.

  1. OakleyForum

    OakleyForum Active Member

    Sever log is filled with this error, and members are saying they can't upload avatars:

    Any idea whats causing it?

    Code:
    ErrorException: exec() has been disabled for security reasons - library/XenForo/Upload.php:197
    Generated By: racs09, 14 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'exec() has been...', '/home/oakleyfo/...', 197, Array)
    #1 /home/oakleyfo/public_html/library/XenForo/Upload.php(197): exec('/usr/bin/mogrif...')
    #2 /home/oakleyfo/public_html/library/XenForo/Upload.php(281): XenForo_Upload->_checkImageState()
    #3 /home/oakleyfo/public_html/library/XenForo/Upload.php(154): XenForo_Upload->_checkForErrors()
    #4 /home/oakleyfo/public_html/library/XenForo/Model/Avatar.php(48): XenForo_Upload->isValid()
    #5 /home/oakleyfo/public_html/library/XenForo/ControllerPublic/Account.php(482): XenForo_Model_Avatar->uploadAvatar(Object(XenForo_Upload), 4806, Array)
    #6 /home/oakleyfo/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Account->actionAvatarUpload()
    #7 /home/oakleyfo/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 /home/oakleyfo/public_html/index.php(13): XenForo_FrontController->run()
    #9 {main}
    Request State
     
  2. OakleyForum

    OakleyForum Active Member

    Fixed it by reuploading upload.php
     

Share This Page