Error upgrading to XF 2.2.7 Patch 1

Sim

Well-known member
Affected version
2.2.5
Tried to run the auto-updater to XF 2.2.7 Patch 1 and received the following errors on several of my sites:

An exception occurred: [Error] Call to undefined method XF\ComposerAutoload::checkPaths() in src/XF.php on line 287

  1. XF::registerComposerAutoloadDir() in src/XF/App.php at line 2334
  2. XF\App->setupAddOnComposerAutoload() in src/XF/Install/App.php at line 160
  3. XF\Install\App->setup() in src/XF.php at line 485
  4. XF::setupApp() in src/XF/Install/_upgrader/core.php at line 1184
  5. XFUpgraderWeb::create() in install/oc-upgrader.php at line 13
 

Sim

Well-known member
I was upgrading from XF 2.2.5, which does not have the XF\ComposerAutoload::checkPaths() method - so there seems to be a quirk with the online upgrader which expects it available?

I will try a manual upgrade now.
 

btmgreg

Well-known member
I wonder if this issue has been fixed with 2.2.8 ? I know the auto upgrader goes through the motions of each version between installed and latest available but I wonder if it'll still choke during the update from 2.2.6 to 2.2.8 ..

Any update? I did see other threads about this but can't find them now :/
 

Chris D

XenForo developer
Staff member
Worth noting that this issue didn’t affect people generally so we’d expect it to be fine.

If you run into any issues though just let us know and we can help. Although uploading files the traditional way would probably be fine if the one click process failed.
 
Top