1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error upgrading 1.2.0 to 1.2.1

Discussion in 'Installation, Upgrade, and Import Support' started by mmcguire, Sep 4, 2013.

  1. mmcguire

    mmcguire Member

    I tried to upgrade from 1.20 to 1.21 and get the following error during the import templates step. I have turned off add-on with $config['enableListeners'] = false; in my config.php file. Any thoughts?

    Code:
    An exception occurred: account_following - Line 25: Else or else if tag not found that was not a direct child of an if tag. in /home/rmo/public_html/library/XenForo/Template/Compiler.php on line 991
    
    XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Tag/If.php at line 30
    XenForo_Template_Compiler_Tag_If->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Hook.php at line 37
    XenForo_Template_Compiler_Tag_Hook->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler/Tag/If.php at line 107
    XenForo_Template_Compiler_Tag_If->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler/Tag/Foreach.php at line 29
    XenForo_Template_Compiler_Tag_Foreach->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Hook.php at line 37
    XenForo_Template_Compiler_Tag_Hook->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
    XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1593
    XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1360
    XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1310
    XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1249
    XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
    XenForo_Deferred_Template->execute() in XenForo/Deferred/Atomic.php at line 61
    XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 198
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 321
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 255
    XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 216
    XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/rmo/public_html/install/index.php at line 18
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    You merged your templates incorrectly. Create a new style and it should be possible to use your site as you go back and determine which template has the error.
     
  3. mmcguire

    mmcguire Member

    How would I do that? When I try the admin panel it says "The board is currently waiting to be upgraded. Please complete the upgrade.".
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you completed the upgrade?
     
  5. mmcguire

    mmcguire Member

    No I get the error in post 1.
     
  6. mmcguire

    mmcguire Member

    1.2.0 was working fine BTW
     
  7. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you PC me admin CP details and your URL?
     

Share This Page