1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error: 'The requested attachment could not be found'

Discussion in 'Troubleshooting and Problems' started by Kenneth Holland, Dec 15, 2013.

  1. Kenneth Holland

    Kenneth Holland Active Member

    Hi,

    On some recent posts on my forum, some images that were posted and have broken image icons. When I click the icon I get:

    'The requested attachment could not be found'

    Can anyone help on how to troubleshoot this?

    Thanks. :)

    Ken
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The attachments must have been removed, either by being deleted from the post by the author or a moderator, via the ACP or from the server directly.
     
    Kenneth Holland likes this.
  3. Kenneth Holland

    Kenneth Holland Active Member

    Hi Brogan,

    Thanks for your quick response.

    Eek! I'm the only one that has access. I didn't remove anything. Hacked maybe? Is there a way to check this?

    Ken
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you are on 1.2 you can check to see if an affected post has been edited.
    If it has that is a possible answer.

    If you try to edit an affected post, presumably there are no attachments and just the BB Code is still present in the post?
     
    Kenneth Holland likes this.
  5. Kenneth Holland

    Kenneth Holland Active Member

    How do check if it's been edited?

    It looks like just the BB Code, yes. I think. Sorry I'm a bit new to this. :)

    Ken
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    If you are on 1.2, have enabled the options and settings and have the permissions, there will be a "History" link at the bottom of the post, next to the other tools such as Edit, Delete, etc.
     
  7. Kenneth Holland

    Kenneth Holland Active Member

    Hi Brogan,

    My apologies! I'm on 1.1.2. I misread it.

    Ken
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Unfortunately there is no edit notification/history in 1.1 so you won't know if post authors have subsequently edited their posts and removed the attachments.
     
    Kenneth Holland likes this.
  9. Kenneth Holland

    Kenneth Holland Active Member

    Ok. I better get this upgraded!

    Thanks for your help! :)

    Ken
     
    oman likes this.

Share This Page