XF 2.1 Error submitting sitemap to Bing

Fastline

Active member
I recently updated XF to 2.1 and i've been receiving sitemap error. The errors are logged as follows.

Stack trace
#0 src/vendor/guzzlehttp/guzzle/src/Middleware.php(66): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Psr7\Request), Object(GuzzleHttp\Psr7\Response))
#1 src/vendor/guzzlehttp/promises/src/Promise.php(203): GuzzleHttp\Middleware::GuzzleHttp\{closure}(Object(GuzzleHttp\Psr7\Response))
#2 src/vendor/guzzlehttp/promises/src/Promise.php(156): GuzzleHttp\Promise\Promise::callHandler(1, Object(GuzzleHttp\Psr7\Response), Array)
#3 src/vendor/guzzlehttp/promises/src/TaskQueue.php(47): GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}()
#4 src/vendor/guzzlehttp/promises/src/Promise.php(246): GuzzleHttp\Promise\TaskQueue->run(true)
#5 src/vendor/guzzlehttp/promises/src/Promise.php(223): GuzzleHttp\Promise\Promise->invokeWaitFn()
#6 src/vendor/guzzlehttp/promises/src/Promise.php(267): GuzzleHttp\Promise\Promise->waitIfPending()
#7 src/vendor/guzzlehttp/promises/src/Promise.php(225): GuzzleHttp\Promise\Promise->invokeWaitList()
#8 src/vendor/guzzlehttp/promises/src/Promise.php(62): GuzzleHttp\Promise\Promise->waitIfPending()
#9 src/vendor/guzzlehttp/guzzle/src/Client.php(131): GuzzleHttp\Promise\Promise->wait()
#10 src/vendor/guzzlehttp/guzzle/src/Client.php(89): GuzzleHttp\Client->request('get', 'https://www.bin...', Array)
#11 src/XF/Sitemap/Builder.php(506): GuzzleHttp\Client->__call('get', Array)
#12 src/XF/Sitemap/Builder.php(430): XF\Sitemap\Builder->sendPing()
#13 src/XF/Sitemap/Builder.php(71): XF\Sitemap\Builder->completeBuild()
#14 src/XF/Job/Sitemap.php(25): XF\Sitemap\Builder->build(G)
#15 src/XF/Job/Manager.php(253): XF\Job\Sitemap->run(G)
#16 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
#17 src/XF/Job/Manager.php(79): XF\Job\Manager->runJobEntry(Array, G)
#18 job.php(42): XF\Job\Manager->runQueue(false, 8)
#19 {main}

My site is verified on bing. Google has no issues. Only bing.
 

Fastline

Active member
I am also get same server error log.
Hmm. When i open the Bing couple of days ago, it said bing webmaster services aren't available right now
What i've done is changed the IP. But the site is verified. I'll try something else.
 
Top