Error on Xenforo when Update to 2.2.8

viglesias

Member
Hi, when update the foro to version I get this errors that I don't know how resolve:


Warning: include(/home/customer/www/foroconspiracion.com/public_html/src/XF/Util/Php.php): failed to open stream: Too many open files in /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php on line 571

Warning: include(): Failed opening '/home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/../../../src/XF/Util/Php.php' for inclusion (include_path='.:/usr/local/php74/pear') in /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php on line 571

Warning: include(/home/customer/www/foroconspiracion.com/public_html/src/XF/Util/Php.php): failed to open stream: Too many open files in /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php on line 571

Warning: include(): Failed opening '/home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/../../../src/XF/Util/Php.php' for inclusion (include_path='.:/usr/local/php74/pear') in /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php on line 571

Fatal error: Uncaught Error: Class 'XF\Util\Php' not found in /home/customer/www/foroconspiracion.com/public_html/src/XF.php:149 Stack trace: #0 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(571): XF::handlePhpError(2, 'include(/home/c...', '/home/customer/...', 571, Array) #1 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(571): include() #2 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(428): Composer\Autoload\includeFile('/home/customer/...') #3 [internal function]: Composer\Autoload\ClassLoader->loadClass('XF\\Error') #4 /home/customer/www/foroconspiracion.com/public_html/src/XF/App.php(989): spl_autoload_call('XF\\Error') #5 /home/customer/www/foroconspiracion.com/public_html/src/XF/Container.php(31): XF\App->XF\{closure}(Object(XF\Container)) #6 /home/customer/www/foroconspiracion.com/public_html/src/XF/App.php(2700): XF\Container->offsetGet('error') #7 /home/customer/www/foroconspiracion.com/pu in /home/customer/www/foroconspiracion.com/public_html/src/XF.php on line 149
 

Chris D

XenForo developer
Staff member
Manually upload the files and run the upgrade process is the traditional way. That should get past this.
 

viglesias

Member
You can download the version you want from the customer area: https://xenforo.com/customers/

And you upload the files to the same place they were uploaded to when the software was installed. There are more detailed instructions in the manual: https://xenforo.com/docs/xf2/
But if I upload the files that I have downloaded from the update -upload folder- it will overwrite the original files that are already in Public_html.

Is this the way to do it? Thank you.
 

ENF

Well-known member
But if I upload the files that I have downloaded from the update -upload folder- it will overwrite the original files that are already in Public_html.

Is this the way to do it? Thank you.
That's the way it normally works. The files you are uploading are the updated files for the version you downloaded, thus overwriting the existing files (the old version).
 

viglesias

Member
That's the way it normally works. The files you are uploading are the updated files for the version you downloaded, thus overwriting the existing files (the old version).
Thank you very much... but once uploaded you have to run the installer - index.php - , to be able to update and tell the system that these are the changes, no? I'm a bit of a novice in Xenforo.
 

viglesias

Member
Thanks, in install/index.php I see... I will make a backup and proceed.
We have the same problem, I upload all the update with ftp but return the same error and don't work the forum.

I have to restore the previous backup to get it working again.


l error: Uncaught Error: Class 'XF\Util\Php' not found in /home/customer/www/foroconspiracion.com/public_html/src/XF.php:149 Stack trace: #0 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(571): XF::handlePhpError(2, 'include(/home/c...', '/home/customer/...', 571, Array) #1 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(571): include() #2 /home/customer/www/foroconspiracion.com/public_html/src/vendor/composer/ClassLoader.php(428): Composer\Autoload\includeFile('/home/customer/...') #3 [internal function]: Composer\Autoload\ClassLoader->loadClass('XF\\Error') #4 /home/customer/www/foroconspiracion.com/public_html/src/XF/App.php(989): spl_autoload_call('XF\\Error') #5 /home/customer/www/foroconspiracion.com/public_html/src/XF/Container.php(31): XF\App->XF\{closure}(Object(XF\Container)) #6 /home/customer/www/foroconspiracion.com/public_html/src/XF/App.php(2700): XF\Container->offsetGet('error') #7 /home/customer/www/foroconspiracion.com/pu in /home/customer/www/foroconspiracion.com/public_html/src/XF.php on line 149
 

djbaxter

Well-known member
I am trying to upgrade one forum to 2.2.8 Patch 1 and getting virtually identical error messages, including "too many opern files".

That sounds like a server or cloudflare error, doesn't it?
 

Chris D

XenForo developer
Staff member
i have no idea why but I totally missed the “too many open files” error in the OP.

That would indeed be an issue caused by limits on the server. Your host may be better placed to provide advice on configuring that.
 

viglesias

Member
Out of curiosity, what would happen if I don't install the latest update? is there a risk of my forum being hacked?
 
Top