1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue Error on new user moderation page with PHP 5.5.1

Discussion in 'Resolved Bug Reports' started by Luke F, Aug 5, 2013.

  1. Luke F

    Luke F Well-Known Member

    This is occurring with enableListeners set to false too, and definitely was not happening before on PHP 5.4.17

    (XF 1.2.0)
     
  2. Mike

    Mike XenForo Developer Staff Member

    I worked this out to be an incompatibility with some of the optimizer settings in Zend Optimizer+. The built in opcode cache in 5.5 is based on this, though I didn't think it had the optimization options.

    There's not a lot that we can do as it simply seems to make the code execute differently than as defined. The only workaround I found was to turn off the optimization levels.
     
    Luke F likes this.
  3. Luke F

    Luke F Well-Known Member

    On closer inspection it seems I can't access the admin CP at all (same error)

    Is there a workaround other than disabling the opcache extension? It's running on basically all default settings
     
  4. Mike

    Mike XenForo Developer Staff Member

    I'm surprised other people haven't run into it (and that I didn't for example, in my tests) if it's a general issue.

    Try setting opcache.optimization_level to 0.
     
  5. Luke F

    Luke F Well-Known Member

    Seems the cause is a conflict between DBG and the opcache extension - disabling DBG fixed it
     
    Mike likes this.
  6. MattW

    MattW Well-Known Member

    Just checked my Ubuntu server at home, and by default it's commented out

    Code:
    ; A bitmask, where each bit enables or disables the appropriate OPcache
    ; passes
    ;opcache.optimization_level=0xffffffff
     
  7. dantreacy

    dantreacy Member

    Using debian Wheezy with dotdeb php5.5 packages here and I found removing php5-xdebug fixed the problem immediately.
     
    Adam Howard likes this.
  8. Sim

    Sim Well-Known Member

    Just FYI - this worked for me.
     
  9. tyteen4a03

    tyteen4a03 Well-Known Member

    Just had a fresh install and ran into this problem. Using 5.4.19. Commenting out zend_extension="ext/php_opcache.dll" solved my problem (I don't need it on my dev server anyways)
     

Share This Page