1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Error On Import (XF to XF)

Discussion in 'Installation, Upgrade, and Import Support' started by yavuz, Aug 9, 2014.

  1. yavuz

    yavuz Well-Known Member

    Hi,

    I'm trying to make an import from a XF board to another, both running on 1.3.4 upon the user import step I'm getting this error:

    Code:
    Mysqli statement execute error : Duplicate entry '2' for key 'PRIMARY'
    
        Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
        Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
        Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
        Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1624
        XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1613
        XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1405
        XenForo_DataWriter->save() in XenForo/Model/Import.php at line 804
        XenForo_Model_Import->importUser() in XenForo/Importer/XenForo.php at line 747
        XenForo_Importer_XenForo->_importUser() in XenForo/Importer/XenForo.php at line 623
        XenForo_Importer_XenForo->_importOrMergeUser() in XenForo/Importer/XenForo.php at line 377
        XenForo_Importer_XenForo->stepUsers() in XenForo/Importer/Abstract.php at line 97
        XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 187
        XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 239
        XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 182
        XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 347
        XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
        XenForo_FrontController->run() in /home/user/public_html/forum/admin.php at line 13
    
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Are you trying to preserve IDs?

    You must uncheck it if there is existing content in the destination database.
     
  3. yavuz

    yavuz Well-Known Member

    Yes, I unchecked it and it went through, thanks!
     

Share This Page