Not a bug Error after applying Paypal fix

Affected version
2.1.0

brunoa

Member
I applied the latest fix but didn't update my installation (big board, too troublesome) and now I see two errors happening. One is the alert that the file has unexpected content, which I think I can just ignore. But after someone made a donation to my forum using PayPal, the following error was returned (I've edited irrelevant/private info).

The donation appeared on my PayPal, but I didn't get the usual warning from the plugin ([TH]donate) informing about the donation.

  • Error: Call to undefined method XF\Repository\Payment::findLogsByTransactionIdForProvider()
  • src/XF/Payment/PayPal.php:268
  • Gerado Por: Conta Desconhecida
  • 9 Maio 2020 às 21:15
Rastreamento de Pilha
#0 payment_callback.php(39): XF\Payment\PayPal->validateTransaction(Object(XF\Payment\CallbackState))
#1 {main}
Solicitar Estado
array(4) {
["url"] => string(40) "/payment_callback.php?_xfProvider=paypal"
["referrer"] => bool(false)
["_GET"] => array(1) {
["_xfProvider"] => string(6) "paypal"
}
["_POST"] => array(33) {
["mc_gross"] => string(5) "10.00"
["protection_eligibility"] => string(10) "Ineligible"
["payer_id"] => string(13) "XXXXX"
["payment_date"] => string(25) "14:23:18 May 09, 2020 PDT"
["payment_status"] => string(9) "Completed"
["charset"] => string(12) "windows-1252"
["first_name"] => string(6) "XXXXXX"
["mc_fee"] => string(4) "1.08"
["notify_version"] => string(3) "3.9"
["custom"] => string(32) "XXXXXXX"
["payer_status"] => string(10) "unverified"
["business"] => string(17) "XXX@XXX.com"
["quantity"] => string(1) "1"
["verify_sign"] => string(56) "XXXXXX"
["payer_email"] => string(23) "XXXX@XXX.com"
["txn_id"] => string(17) "00349938U5467512K"
["payment_type"] => string(7) "instant"
["last_name"] => string(27) "XXXX"
["receiver_email"] => string(17) "XXX@XXX.com"
["payment_fee"] => string(0) ""
["shipping_discount"] => string(4) "0.00"
["receiver_id"] => string(13) "XXXXXX"
["insurance_amount"] => string(4) "0.00"
["txn_type"] => string(10) "web_accept"
["item_name"] => NULL
["discount"] => string(4) "0.00"
["mc_currency"] => string(3) "BRL"
["item_number"] => string(0) ""
["residence_country"] => string(2) "BR"
["shipping_method"] => string(7) "Default"
 

Masetrix

Well-known member
This is the Patch you need

Therefore if you are using XenForo 2.1.0 - 2.1.4 you should use the attached xf-patch-214.zip rather than the xf-patch-219.zip patch mentioned in the first post.
 

brunoa

Member
because this fix was not for 2.1.0. and for versions above

I followed the original instructions and wasn't aware of this newest fix.

This is the Patch you need


Thank you!
 
Top