• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Empty admin.php after 1.4.8 -> 1.4.10 upgrade

#1
Problem:
  • I upgraded from 1.4.8. to 1.4.10
  • The admin.php is delivered completely empty (no content at all)
  • HTTP status code for the admin.php is 200
  • the frontend works fine though
What did I try to fix the issue?
  • I tried to rebuild the master data via the install tool (at least 5 times) -> no effect
  • I tried to disable the memcache (see config below) and tried to rebuild the master data -> no effect
  • I tried to access a sub page on admin.php -> empty page as well.
  • I tried to activate display_errors -> no errors get displayed.
Further information

  • webserver is nginx, database is Maria DB
  • Here is my config (dummy values for the actual config values):
  • PHP:
    ini_set('display_errors', true);
    $config['db']['host'] = '1.2.3.4';
    $config['db']['port'] = '1234';
    $config['db']['username'] = 'dbuser';
    $config['db']['password'] = 'password';
    $config['db']['dbname'] = 'prefix_xenforum';
    
    $config['cache']['enabled'] = true;
    $config['cache']['cacheSessions'] = true;
    $config['cache']['frontend'] = 'Core';
    //$config['cache']['frontendOptions']['automatic_serialization'] = true;
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_prefix_';
    /*
    $config['cache']['backend'] = 'Memcached';
    $config['cache']['backendOptions'] = array(
        'compression' => true,
        'servers' => array(
            array(
                // your memcached server IP /address
                'host' => '1.2.3.4',
    
                // memcached port
                'port' => 11211,
            ),
                    array(
                            // your memcached server IP /address
                            'host' => '1.2.3.4',
    
                            // memcached port
                            'port' => 11211,
                    )
        )
    );
    */
    $config['superAdmins'] = '1234';
    $config['debug'] = true;
    $config['cookie']['domain'] = '.mydomain.xyz';
Questions
  • Any idea how to fix this issue?
  • What's the cause of this?