1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Email in-use error? nginx + php-fpm

Discussion in 'Troubleshooting and Problems' started by Nomy, Feb 26, 2014.

  1. Nomy

    Nomy Member

    Hello,

    Everytime someone tries to enter email and click away, the site shows an error. I am not sure what could be the problem. I think it only happens in debug mode.

    [​IMG]

    Here are the logs:

    Nginx error log:
    Code:
    2014/02/26 16:11:57 [error] 24892#0: *23 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:12:23 [error] 24892#0: *23 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:30:11 [error] 24892#0: *2917 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:45:30 [error] 24892#0: *4054 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:49:45 [error] 24892#0: *4320 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:51:08 [error] 24892#0: *4418 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    2014/02/26 16:51:31 [error] 24892#0: *4418 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XXX.XXX.XXX.XXX, server: domain.com, request: "POST /test/register/validate-field HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "domain.com", referrer: "http://domain.com/test/login/login"
    Php error log:
    Code:
    [26-Feb-2014 16:11:57] WARNING: [pool domain] child 22341 exited on signal 11 (SIGSEGV) after 675.747648 seconds from start
    [26-Feb-2014 16:11:58] NOTICE: [pool domain] child 24907 started
    [26-Feb-2014 16:12:23] WARNING: [pool domain] child 22340 exited on signal 11 (SIGSEGV) after 705.344271 seconds from start
    [26-Feb-2014 16:12:23] NOTICE: [pool domain] child 25332 started
    [26-Feb-2014 16:30:11] WARNING: [pool domain] child 24907 exited on signal 11 (SIGSEGV) after 1093.024607 seconds from start
    [26-Feb-2014 16:30:11] NOTICE: [pool domain] child 28052 started
    [26-Feb-2014 16:45:30] WARNING: [pool domain] child 25332 exited on signal 11 (SIGSEGV) after 1986.788713 seconds from start
    [26-Feb-2014 16:45:30] NOTICE: [pool domain] child 30447 started
    [26-Feb-2014 16:49:45] WARNING: [pool domain] child 28052 exited on signal 11 (SIGSEGV) after 1174.432294 seconds from start
    [26-Feb-2014 16:49:45] NOTICE: [pool domain] child 30875 started
    [26-Feb-2014 16:51:08] WARNING: [pool domain] child 30875 exited on signal 11 (SIGSEGV) after 82.582952 seconds from start
    [26-Feb-2014 16:51:08] NOTICE: [pool domain] child 31299 started
    [26-Feb-2014 16:51:31] WARNING: [pool domain] child 30447 exited on signal 11 (SIGSEGV) after 360.936282 seconds from start
    [26-Feb-2014 16:51:31] NOTICE: [pool domain] child 31305 started
    Regards
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Nomy

    Nomy Member

    Thanks Jake.

    I think it was memcache for me.

    So people with similar problem in future should try removing memcache
    apt-get remove php5-memcache

    Thanks
     

Share This Page