1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Email Error

Discussion in 'Troubleshooting and Problems' started by Mr Lucky, Mar 16, 2016.

  1. Mr Lucky

    Mr Lucky Well-Known Member

    I got this error:

    Zend_Mail_Protocol_Exception: Email to xxxx@xxxxxx.ws failed (after retry): Connection refused - library/Zend/Mail/Protocol/Abstract.php:277
    Generated By: Unknown Account, Yesterday at 8:12 PM
    Stack Trace
    #0 /home/xxxxx/public_html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('tcp://smtp.spar...')
    #1 /home/xxxxx/public_html/library/Zend/Mail/Transport/Smtp.php(216): Zend_Mail_Protocol_Smtp->connect()
    #2 /home/xxxxx/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /home/xxxxx/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /home/xxxxx/public_html/library/XenForo/Model/MailQueue.php(91): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /home/xxxxx/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.99999904633)
    #6 /home/xxxxx/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_MailQueue->execute(Array, Array, 7.99999904633, '')
    #7 /home/xxxxx/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.99999904633, '', false)
    #8 /home/xxxxx/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #9 /home/xxxxx/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    Request State
    array(3) {
      ["url"] => string(37) "http://domain.com/deferred.php"
      ["_GET"] => array(0) {
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(64) "/threads/red-kites-other-birds-wildlife-in-general.11887/page-57"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
    Can someone please tell me what this means?

    The user says she is receiving notifications.

    The user says their email is fine, and a test email to that address appears to be fine.

  2. Tracy Perry

    Tracy Perry Well-Known Member

    Looks like your SMTP server (SparkPost?) refused the connection from your server.
  3. Mr Lucky

    Mr Lucky Well-Known Member

    Thanks ... So does that mean it's just a glitch in sparkpost as opposed to a bad email address?
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Tracy Perry

    Tracy Perry Well-Known Member

    If it was a bad email, you would typically get a different error - but odds are NOT from the ACP as you hand the mail off to your SMTP server, which would be responsible for any logs of a refusal of acceptance of delivery (unless you are using the bounce feature). What yours shows is an error of the connection from your server to your SMTP provider. If this is a one time deal, it's probably not a worry. If you see many of them then there is an issue that needs to be resolved.
  6. Solidus

    Solidus Well-Known Member

    Have you opened up port 2525? (or whichever you used)
  7. Mr Lucky

    Mr Lucky Well-Known Member

    No, this seems to be a one-off. I've been using Sparkpost for a couple of weeks and no complaints or errors until this one.

    I have port 587 in the ACP settings, I'm not sure what you mean by "opened up?"
  8. Solidus

    Solidus Well-Known Member

    Either in iptables or any firewall manager you use. You need to allow port 587 on tcp protocol for outgoing connections.
  9. Mr Lucky

    Mr Lucky Well-Known Member

    I appreciate the help but, er, sorry. I have no idea what any of that means :)
  10. Solidus

    Solidus Well-Known Member

    If it's shared hosting or managed vps, they'll do it for you.
  11. MattW

    MattW Well-Known Member

    That port is already open, as it's the standard outbound port.
  12. Mr Lucky

    Mr Lucky Well-Known Member

    Thanks Matt!

Share This Page