• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Email bouncing server error

Mouth

Well-known member
#1
Code:
Server Error Log
Error Info
Zend_Mail_Protocol_Exception: Email to admin@redacted.com failed: <bounces+f270b6e3+ admin=redacted.com@redacted.com> Invalid email address. - library/Zend/Mail/Protocol/Abstract.php:431
Generated By: Unknown Account, Today at 04:03
Stack Trace
#0 library/Zend/Mail/Protocol/Smtp.php(261): Zend_Mail_Protocol_Abstract->_expect(Array, 300)
#1 library/Zend/Mail/Transport/Smtp.php(224): Zend_Mail_Protocol_Smtp->mail('bounces+f270b6e...')
#2 library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#5 library/SV/EmailQueue/XenForo/Mail.php(21): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 library/XenForo/Mail.php(152): SV_EmailQueue_XenForo_Mail->sendMail(Object(Zend_Mail))
#7 library/XenForo/Mail.php(214): XenForo_Mail->send(' admin@netrider...', NULL, Array, '', '', '')
#8 library/Andy/AttachmentCheck/CronEntry/AttachmentCheck.php(186): XenForo_Mail->queue(' admin@redacted.com...', NULL)
#9 library/XenForo/Model/Cron.php(356): Andy_AttachmentCheck_CronEntry_AttachmentCheck::runAttachmentCheck(Array)
#10 library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
#11 library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 8, '')
#12 library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 8, '', false)
#13 library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#14 deferred.php(23): XenForo_Model_Deferred->run(false)
#15 {main}
Request State
array(3) {
  ["url"] => string(36) "https://redacted.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
   ["_xfRequestUri"] => string(23) "/find-new/3747461/posts"
   ["_xfNoRedirect"] => string(1) "1"
   ["_xfToken"] => string(8) "********"
   ["_xfResponseType"] => string(4) "json"
  }
}
I'm not sure what the above server error message is telling me that needs fixing? admin@redacted.com is a valid email address and domain (apart from the 'redcated' bit of course.
 

Mike

XenForo developer
Staff member
#2
There may be something that we can improve a bit with our code checking, but this appears to be related to an add-on:
Code:
#8 library/Andy/AttachmentCheck/CronEntry/AttachmentCheck.php(186): XenForo_Mail->queue(' admin@redacted.com...', NULL)
It's passing the email in with a space.
 

Mouth

Well-known member
#5
Check the Options page for the add-on Attachment Check, the Email To option appears to have an extra space before the email address.
Thx.
I had multiple, separated by comma, with a space after the comma before the next email address.