• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Elasticsearch stopped working after website crash

owls8521

Active member
#1
Elasticsearch was working fine for me for a few months... but then one day my web host had a problem, and the website crashed. I had to repair the Xenforo database, and then I restarted Elasticsearch. Everything seemed to be working fine. However, after maybe 30 minutes or so, Elasticsearch stopped working. Every time I restart it, it works for a while and then stops; and then I get this in Xenforo's server error log:
XenForo_Exception: Elasticsearch server returned no response. Is it running? - library/XenES/Search/SourceHandler/ElasticSearch.php:850
I've looked at as many logs as I could find, and I know that the java virtual machine is crashing because of this message:
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fe7a2a37dc3, pid=21651, tid=140630601455360
#
# JRE version: OpenJDK Runtime Environment (8.0_31-b13) (build 1.8.0_31-b13)
# Java VM: OpenJDK 64-Bit Server VM (25.31-b07 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V [libjvm.so+0x421dc3]
I've even tried using different versions of Java and it doesn't make a difference. The other version I tried was 8.0_25.

Does anyone have any idea why it would stop working after a crash when it was working fine before? I've spent a lot of time trying to fix it and haven't gotten anywhere. Any help is greatly appreciated.
 

owls8521

Active member
#3
I tried reinstalling it and it did not fix the issue. I did find a solution though. The JVM crashes were being caused by the Similar Threads add-0n. When I disabled it, they stopped happening.

I have a theory of why this started happening after the website crashed. Apparently, the Similar Threads add-on autodetects Enhanced Search, but since I didn't have it installed when I first installed the Similar Threads add-on, Enhanced Search wasn't being used. I am thinking that it still wasn't using it after Enhanced Search was set up. After the website crashed, everything was restarted, so now Similar Threads was using Enhanced Search. There must be a bug with Similar Threads that causes it to crash the JVM on my website when it uses Enhanced Search. It works fine when it uses normal search.

So at least everything makes sense in my brain now, unless I am wrong... but I learned some stuff, so good times.
 

owls8521

Active member
#4
I was wrong. It still crashed even without the Similar Threads add-on. It just took longer. It took about 18 hours to crash instead of about a half hour like it does with the Similar Theads add-on enabled. Does anyone have any advice?
 

owls8521

Active member
#6
The only solution was for me to switch web hosts and move to a completely different server. I assume something went wrong with the hardware the VPS I was on, but the technical support people all told me there were no problems with it. It was very strange and frustrating. I've never felt so helpless with a problem on my website.

A lot of good came out of it though because my new setup is better and cheaper than the previous one. :D
 

vinafix

Active member
#7
I was offered a fix as you have not you.

Elasticsearch server returned no response. Is it running?4 minutes ago - library/XenES/Search/SourceHandler/ElasticSearch.php:850
Screen Shot 2015-03-21 at 8.34.49 PM.png

someone help me with

Thanks you.