1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Full Friendly URLs stopped working after Fresh install

Discussion in 'Installation, Upgrade, and Import Support' started by iTuN3r, Feb 13, 2011.

  1. iTuN3r

    iTuN3r Well-Known Member

    Had to clean up everything and do fresh install on my test board ....Full Friendly URLs is not working after installing . I am getting such errors even for Pop up boxes when friendly url is enabled .

    Everything is working fine when friendly url's are disabled. what could be the reason ? i checked htaccess file too everything seems to be fine.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Can you download the .htaccess file from the server forum directory and post the contents here?

    If everything works with friendly URLs disabled then it's usually an .htaccess related issue.
  3. iTuN3r

    iTuN3r Well-Known Member

  4. iTuN3r

    iTuN3r Well-Known Member

    I have xen Portal installed and somehow with Friendly URL's only portal page loads any other links are not working here's error when i click forum

    The requested URL /forum/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
  5. iTuN3r

    iTuN3r Well-Known Member

    Re-uploading the files fixed the issue .
    Tomble likes this.
  6. Tomble

    Tomble Active Member

    Hey, I have the same issue. Did you re-upload all the XenForo files in the upgrade package or did you download the full package again? Just wondering as hoping to do this tomorrow. Thanks :).
  7. iTuN3r

    iTuN3r Well-Known Member

    Full Package .
  8. DaveL

    DaveL Well-Known Member

    Ive been having similar isssues and managed to solve some of them by reuploading the full package, but I still have this problem:

    In Firefox:
    www.mysite.com - If you click on "forum" from the portal page, it just reloads the portal page, however if you goto http://mysite.com it loads the forum page fine.

    In IE and Chrome it works fine either using www. or without the www.

    Any ideas what may be causing this?
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I need to see your site to test the problem.

    Inconsistent links can cause problems. I recommend enforcing just one subdomain ("www" or not). See #2:

    DaveL likes this.
  10. DaveL

    DaveL Well-Known Member

    Hi Jake,

    Thanks for the reply.

    After days of trying to get this sorted, I finally found out what the problem was! I needed to clear my cache in FF. Since doing that its been working fine!
  11. DaveL

    DaveL Well-Known Member

    I seem to be having the same issue again with another installation of Xenporta.

    If I have friendly urls enabled, it only redirects to the portal page. If I disable friendly urls, it seems to work fine!

    I have tried reuploading all the Xenforo files and also deleteing my cache, but not luck.

    As I have IPB redirect in my htaccess, could that have anything to do with it?

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /ip.board
        # IPS Rewrite Rules
        RewriteCond %{REQUEST_URI} /(topic|forum|user)/ [OR]
        RewriteCond %{QUERY_STRING} (^|&)show(topic|forum|user)= [OR]
        RewriteCond %{QUERY_STRING} ^/(topic|forum|user)/ [OR]
        RewriteCond %{PATH_INFO} ^/(topic|forum|user)/
        RewriteRule ^.*$ ips2xf.php [NC,L]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d   
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Those IPB redirects should be fine.

    404 friendly URLs usually means one of two things:

    1) Your server doesn't have mod_rewrite installed.

    2) Your server doesn't have AllowOverride enabled:


    edit... three things:

    3) The .htaccess file is not in place in your forum directory.

    edit... no wait, four:

    4) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

Share This Page