1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Elasticsearch is Working

Discussion in 'Enhanced Search Support' started by Nirjonadda, May 13, 2016.

  1. Nirjonadda

    Nirjonadda Active Member

    Elasticsearch is working But getting error via index.php?search/search "The search could not be completed. Please try again later."
     

    Attached Files:

  2. Chris D

    Chris D XenForo Developer Staff Member

    The Elastic Search log will be the best thing to check in the first instance.
     
  3. Nirjonadda

    Nirjonadda Active Member

    Where i can check Elastic Search log?
     
  4. Nirjonadda

    Nirjonadda Active Member

    Does Elasticsearch work with ConfigServer Security & Firewall? On my hand Elasticsearch work if Disabled ConfigServer Security & Firewall but i Allow incoming TCP ports 9200,9300 but still are not work.
     
  5. duderuud

    duderuud Active Member

    You can usually find the logs in /var/log/elasticsearch
     
  6. Nirjonadda

    Nirjonadda Active Member

    Does Elasticsearch work with ConfigServer Security & Firewall? On my hand Elasticsearch work if Disabled ConfigServer Security & Firewall but i Allow incoming TCP ports 9200,9300 but still are not work.
     
  7. Slavik

    Slavik XenForo Moderator Staff Member

    You have a misconfiguration then.
     
  8. Nirjonadda

    Nirjonadda Active Member

    Then what configuration need to doing? Only problem with CSF firewall if enabled.
     
  9. Slavik

    Slavik XenForo Moderator Staff Member

    That would be down to your sysadmin to locate. However I know of many boards using CSF and ES without issue.
     
  10. Nirjonadda

    Nirjonadda Active Member

    I think i have fixed this issue to adding in csf.pignore for Suspicious process running. now i am getting Suspicious File Alert via email.

    Read more here : https://discuss.elastic.co/t/suspicious-file-alert/50068
     
  11. Travis-Mc

    Travis-Mc Member

    Did you resolve this? I'm having the same problem.

    Time: Mon Jun 27 21:25:28 2016 -0400
    File: /tmp/jna--1985354563/jna1167069209280915558.tmp
    Reason: Linux Binary
    Owner: elasticsearch:elasticsearch (987:984)
    Action: No action taken
     
  12. Travis-Mc

    Travis-Mc Member

    A little update. I fixed the constant suspicious file alerts by ignoring the whole directory.

    I added the following to csf.fignore
    /tmp/jna\-\-1985354563/

    I'm not sure if it's the best solution, but I think the alerts were false positives.
     

Share This Page