• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Elasticsearch error: SearchPhaseExecutionException

bukoo

New member
#1
Hi,

We have a problem in member profile on the posts tab. Search on site (elastic search) is working. But this posts tab giving error on all members profile. We deleted and rebuild indexes several times.

The error is:

Elasticsearch error: SearchPhaseExecutionException[Failed to execute phase [query], all shards failed; shardFailures {[K75a4safSDaqtnHYQh1IBg][bodyforum][0]: SearchParseException[[bodyforum][0]: from[-1],size[15],sort[<custom:"date": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@3537895d>!]: Parse Failure [Failed to parse source [{"size":15,"sort":[{"date":"desc"}],"fields":[],"query":{"field":{"user":118945}}}]]]; nested: QueryParsingException[[bodyforum] No query registered for [field]]; }{[K75a4safSDaqtnHYQh1IBg][bodyforum][1]: SearchParseException[[bodyforum][1]: from[-1],size[15],sort[<custom:"date": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@7611636f>!]: Parse Failure [Failed to parse source [{"size":15,"sort":[{"date":"desc"}],"fields":[],"query":{"field":{"user":118945}}}]]]; nested: QueryParsingException[[bodyforum] No query registered for [field]]; }{[K75a4safSDaqtnHYQh1IBg][bodyforum][2]: SearchParseException[[bodyforum][2]: from[-1],size[15],sort[<custom:"date": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@6f9748f7>!]: Parse Failure [Failed to parse source [{"size":15,"sort":[{"date":"desc"}],"fields":[],"query":{"field":{"user":118945}}}]]]; nested: QueryParsingException[[bodyforum] No query registered for [field]]; }{[K75a4safSDaqtnHYQh1IBg][bodyforum][3]: SearchParseException[[bodyforum][3]: from[-1],size[15],sort[<custom:"date": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@76b9287d>!]: Parse Failure [Failed to parse source [{"size":15,"sort":[{"date":"desc"}],"fields":[],"query":{"field":{"user":118945}}}]]]; nested: QueryParsingException[[bodyforum] No query registered for [field]]; }{[K75a4safSDaqtnHYQh1IBg][bodyforum][4]: SearchParseException[[bodyforum][4]: from[-1],size[15],sort[<custom:"date": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@7611636f>!]: Parse Failure [Failed to parse source [{"size":15,"sort":[{"date":"desc"}],"fields":[],"query":{"field":{"user":118945}}}]]]; nested: QueryParsingException[[bodyforum] No query registered for [field]]; }] - library/XenES/Search/SourceHandler/ElasticSearch.php:740
Oluşturan: Bukoo, Az önce
Yığın Takibi


#0 /home/nginx/domains/bodyforumtr.com/public/library/XenES/Search/SourceHandler/ElasticSearch.php(432): XenES_Search_SourceHandler_ElasticSearch->_logSearchResponseError(Object(stdClass), true)
#1 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/ControllerPublic/Member.php(627): XenES_Search_SourceHandler_ElasticSearch->executeSearchByUserId(118945, 0, 15)
#2 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Member->actionRecentContent()
#3 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#4 /home/nginx/domains/bodyforumtr.com/public/index.php(13): XenForo_FrontController->run()
#5 {main}


array(3) {
["url"] => string(214) "http://www.bodyforumtr.com/members/...a567fd2d425305dcd62e05c7&_xfResponseType=json"
["_GET"] => array(5) {
["/members/bukoo_118945/recent-content"] => string(0) ""
["_xfRequestUri"] => string(22) "/members/bukoo.118945/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(58) "118945,1403888243,096a0fa9d9a0ce68a567fd2d425305dcd62e05c7"
["_xfResponseType"] => string(4) "json"
}
["_POST"] => array(0) {
}
}
 

bukoo

New member
#3
curl http://127.0.0.1:9200

"status" : 200,
"name" : "Zaladane",
"version" : {
"number" : "1.2.1",
"build_hash" : "6c95b759f9e7ef0f8e17f77d850da43ce8a4b364",
"build_timestamp" : "2014-06-03T15:02:52Z",
"build_snapshot" : false,
"lucene_version" : "4.8"
},

This is the version of ES. I do not know properly but we have moved forum to a new hosting company. But as I said, search works fine which uses the same ES.
 

Mike

XenForo developer
Staff member
#6
If you're using a recent version of Elasticsearch, you need to use the 1.1 series of XFES to be full compatible.
 

bukoo

New member
#7
Hi,

I have done the upgrade steps as on http://xenforo.com/help/enhanced-search/

But when I tried to upgrade from admin /admin.php?add-ons/XenES/upgrade
it gives this error:
XenForo Enhanced Search requires XenForo 1.3.0 or newer.

Note: Our xenforo version is: 1.2.2
Note: In the top of the file "addon-XenES.xml" that I have uploaded to server, I see:

<addon addon_id="XenES" title="XenForo Enhanced Search" version_string="1.1.0" version_id="1010070" url="http://xenforo.com" install_callback_class="XenES_Install" install_callback_method="install" uninstall_callback_class="XenES_Install" uninstall_callback_method="uninstall">