1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Edit Icons go Blank When People Turn Colors Off

Discussion in 'XenForo Questions and Support' started by Dan Allen, Oct 12, 2015.

  1. Dan Allen

    Dan Allen Active Member

    XF edit control icons become blank when people turn off their site colors. I never heard of people doing this before, but evidently, some people with seeing problems do this

    Here is what XF text editor looks like when colors are turned off:

    View attachment 119069
    Last edited: Oct 12, 2015
  2. Daniel Hood

    Daniel Hood Well-Known Member

    I have no idea why you would want to view a website in black and white but I would imagine a custom style would look/work the best.
  3. Amaury

    Amaury Well-Known Member

    If you're just looking for something extremely basic--in other words, just a simple re-color--I can whip up a black and white style.
  4. Dan Allen

    Dan Allen Active Member

    I misstated the report. The report says most browsers, not most sites, have an option for turning off colors and background images for people with certain kinds of vision problem. The problem is that XF edit control icons use background images, so when colors are turned off, the edit control icons go blank. Here is a screenshot of this. I installed an addon to Firefox to check this out


    For kicks, I took a look at tinymce and with colors turned off, here is what you get:
  5. Mike

    Mike XenForo Developer Staff Member

    This is really a problem with the Firefox add-on. It's removing any "background" image which is an incredibly common technique and is used here. There isn't really anything we can do about it (we can't really support browser extensions that make arbitrary changes to the page HTML/CSS).

Share This Page