EasyApache 4 and PHP 7 - compatible?

actionmedia

Active member
Hello - If I upgrade to Apache 4 and PHP 7, is XF 1.5 compatible, or am I going to cause an issue? Thank you.
 

S Thomas

Well-known member
Upon upgrading you will need to activate the PHP extensions for PHP7 again which XF needs. Most likely mysqlnd, mb_string, curl and stuff like that. Other than that it should work, depending on which version of XF1.5 you are using.
 

Live Free

Active member
Upon upgrading you will need to activate the PHP extensions for PHP7 again which XF needs. Most likely mysqlnd, mb_string, curl and stuff like that. Other than that it should work, depending on which version of XF1.5 you are using.
Is there a list of required PHP extensions?
 

Ozzy47

Well-known member
XenForo System Requirements

PHP: 5.4.0+ (PHP 7.2.0+ recommended)
MySQL: 5.5+ (MariaDB / Percona also compatible)
PHP extensions: MySQLi, GD (with JPEG support), PCRE, cURL, SPL, SimpleXML, DOM, JSON, iconv, ctype
Common PHP functions must not be disabled
 
Top