Http links are returning 404 after EasyApache and PHP upgrade

Jeffin

Well-known member
Hi, I had recently added an SSL certificate to my website. Then I got my hosting provider to upgrade EasyApache from 3 to 4 and PHP version from 5.3 to 7.2. After that this problem is happening which even they are finding it difficult to understand.

The front page of my forum is accessible via its non https url http://christianforumsite.com but if you go anymore deeper like example http://christianforumsite.com/forums/welcome/, it returns a 404 error.
Weird thing is that the front page of its https url https://christianforumsite.com and deeper https links like example https://christianforumsite.com/forums/welcome/ are all functional.

Any idea what may be causing this issue. Thanks.
 

Yodrak

Member
You need a automatic redirect to your https Site.
Open your .htaccess in your webroot Folder and copy and paste this:

Code:
RewriteEngine On 
RewriteCond %{HTTPS} !=on 
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
If you don't have a .htaccess in your Webroot then take a look in the htaccess.txt there and change it to your belongings or let your Hoster do this Stuff if you're unsure.
 

Jeffin

Well-known member
You need a automatic redirect to your https Site.
Open your .htaccess in your webroot Folder and copy and paste this:

Code:
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
If you don't have a .htaccess in your Webroot then take a look in the htaccess.txt there and change it to your belongings or let your Hoster do this Stuff if you're unsure.
Hi Yodrak, thanks for replying back. I could redirect http to https as a band-aid solution. But I wanted both http as well https to work before implementing the re-direct via .httaccess. :)
 
Top